incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hahn <m...@hahnca.com>
Subject Re: starting couch on linux boot from build-couchdb
Date Sat, 24 Dec 2011 10:40:57 GMT
> Have you looked into /root/build-couchdb/build/var/log/couchdb/couch.log ?

Thanks for pointing that out. That file only has old info in it since I
changed /root/build-couchdb/build/etc/couchdb/local.ini to the settings
shown here.

---------------  local.ini --------------
[couchdb]
database_dir    = /mnt/db/couch_dbs
view_index_dir  = /mnt/db/couch_views
uri_file             = /mnt/db/couch.uri

[httpd]
bind_address = 0.0.0.0

[couch_httpd_auth]
secret = xxxxxxxxxxxxxxxxxxxxxx
require_valid_user = true

[log]
level = debug
include_sasl = false
file = /mnt/db/couch.log

[admins]
root = -xxxxxxxxxxxxxxxxxxxxxxxxxx

[uuids]
algorithm = utc_random


After booting, /mnt/db/ is there, but the log file is missing.  It isn't
being created.  There is no permission issue since everything is running as
root.

I just now discovered that when I run couchdb manually, futon works fine
but I'm still not getting a log file created.

Is it possible this log problem is the root of the big problem?  Can I
debug to find out where the log is ending up?  I did a find / -name
*couchdb.log and only the one old location showed up.  Can couch run
without a log file?

I looked at the db configuration using futon and it matched my local.ini
file.

Have I given any new hints to the problem?  I need more help.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message