incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hahn <m...@hahnca.com>
Subject Re: starting couch on linux boot from build-couchdb
Date Sat, 24 Dec 2011 23:33:16 GMT
Thanks for the help.  This worked in my init script ...

    /root/build-couchdb/build/etc/init.d/couchdb start
I didn't know about the init.d/couchdb file.  I didn't find it in my
googling.  I guess I should have browsed through the whole build
directory tree.

I'm still not able to find my log file anywhere on my disk.  The
configuration page in futon agrees with what I put in my local.ini
file.

    log
    ---
    file                 /mnt/db/couch.log
    include_sasl   false
    level               debug

This is what I get from your _log suggestion at boot and even when
starting it manually ...

     curl http://root:tbgcomps2@localhost:5984/_log
    {"error":"badmatch","reason":"{error,enoent}"}

Could this be a permission problem?  I set up everything as root and
the couch config says to run couch as root, which it does.  How else
could permission fail for something as simple as writing a log?

Mime
View raw message