incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CGS <cgsmcml...@gmail.com>
Subject Re: Authentication failure with "Minor error in HTTP request"
Date Wed, 07 Dec 2011 11:39:49 GMT

There is nothing wrong with this part of the log. My suggestion is to 
look for errors during the test.

CGS


On 12/07/2011 12:07 PM, Ramkrishna Kulkarni wrote:
> During some rigorous testing, one of our scripts is making around 250K
> GET requests (all different paths) with basic auth. Before this test,
> all users are able to login but after the test, only a couple of them
> are able to login. For all other valid users I see unauthorized
> message in the logs (mentioned below).
>
> I have changed only the following auth settings
> auth_cache_size = 50000
> timeout = 3600 ;seconds
>
> I'm currently on 1.0.2.
>
> Please help.
>
> --- Logs ----
> Wed, 07 Dec 2011 10:56:21 GMT] [debug] [<0.23516.2>] 'POST' /_session {1,1}
> Headers: [{'Accept',"application/json, text/javascript, */*; q=0.01,
> application/json"},
>            {'Accept-Charset',"UTF-8,*;q=0.5"},
>            {'Accept-Encoding',"gzip,deflate,sdch"},
>            {'Accept-Language',"en-US,en;q=0.8,hi;q=0.6"},
>            {'Connection',"keep-alive"},
>            {'Content-Length',"59"},
>            {'Content-Type',"application/x-www-form-urlencoded"},
>            {'Cookie',"AuthSession="},
>            {'Host',"xxx.xxx.xx.xxx:5984"},
>            {"Origin","http://xxx.xxx.xx.xxx:5984"},
>            {'Referer',"http://xxx.xxx.xx.xxx:5984/"},
>            {'User-Agent',"Mozilla/5.0 (X11; Linux i686)
> AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.120
> Safari/535.2"},
>            {"X-Requested-With","XMLHttpRequest"}]
>
> [Wed, 07 Dec 2011 10:56:21 GMT] [debug] [<0.23516.2>] OAuth Params: []
>
> [Wed, 07 Dec 2011 10:56:21 GMT] [debug] [<0.23516.2>] Attempt Login:
> FXXXXXXXe16b2658b5c8f8ed3dcd09d36d08f107
>
> [Wed, 07 Dec 2011 10:56:21 GMT] [info] [<0.23516.2>] yyy.yyy.yyy.yyy -
> - 'POST' /_session 401
>
> [Wed, 07 Dec 2011 10:56:21 GMT] [debug] [<0.23516.2>] httpd 401 error response:
>   {"error":"unauthorized","reason":"Name or password is incorrect."}
>
> --- end ---


Mime
View raw message