incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kwasi Gyasi - Agyei <kwasi.gyasiag...@4things.co.za>
Subject Re: Installing CouchDB on CentOS 6/32Bit
Date Fri, 11 Nov 2011 20:05:04 GMT
Building Erlang (otp_src_R14B04)
Source URL : http://www.erlang.org/download/otp_src_R14B04.tar.gz<http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz>
------------------------------
+ Steps

$ wget http://www.erlang.org/download/otp_src_R14B04.tar.gz
$ tar -xvf otp_src_R14B04.tar.gz
$ ./configure

+ Problem/Error:
configure: error: No curses library functions found
configure: error: /bin/sh
'/usr/local/downloads/couchdb-installation-files/otp_src_R14B04/erts/configure'
failed for erts

+ Resolution:
$yum install ncurses ncurses-devel

On Fri, Nov 11, 2011 at 9:18 PM, Kwasi Gyasi - Agyei <
kwasi.gyasiagyei@4things.co.za> wrote:

> Thanks, you were correct I was missing gcc-c++.
> $yum install gcc-c++
>
> I have epel configured, however I want to install the latest couchdb 1.1.1.
> On Nov 11, 2011 9:05 PM, "Nils Breunese" <N.Breunese@vpro.nl> wrote:
>
>> Sounds like you're missing a C++ compiler. Have you tried installing
>> gcc-c++ via yum?
>>
>> Some other ideas to get CouchDB running on CentOS 6:
>>
>> * The EPEL repository has CouchDB 1.0.2 ready-to-go in its repository:
>> http://fedoraproject.org/wiki/EPEL
>> * build-couchdb: https://github.com/iriscouch/build-couchdb
>>
>> Nils.
>> ________________________________________
>> Van: Kwasi Gyasi - Agyei [kwasi.gyasiagyei@4things.co.za]
>> Verzonden: vrijdag 11 november 2011 19:53
>> Aan: user@couchdb.apache.org
>> Onderwerp: Installing CouchDB on CentOS 6/32Bit
>>
>> Hi All,
>>
>> I'm trying to build CouchDB on Centos 6, I have installed most of the
>> dependencies using yum install, listed below:
>>
>> $ yum install gcc libtool xulrunner-devel libicu-devel openssl-devel icu
>> automake autoconf automake213
>>
>> Below I'm going to detail the dependencies installed, as a way to also
>> possible produce steps for someone who may possible come across the issue
>> encountered along with resolutions
>>
>> Building SpiderMonkey (js-1.8.5)
>> Source URL : http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
>> ------------------------------
>> + Steps
>>
>> $ wget http://ftp.mozilla.org/pub/mozilla.org/js/js185-1.0.0.tar.gz
>> //instructions from
>>
>> https://developer.mozilla.org/En/Developer_Guide/Build_Instructions/Linux_Prerequisites
>> ,
>> I left out mercurial, believe it is used for source checkout
>> $ yum install mercurial autoconf213 glibc-static libstdc++-static yasm
>> wireless-tools-devel mesa-libGL-devel alsa-lib-devel libXt-devel$ cd
>> js-1.8.5/src/js
>> $ autoconf-2.13
>> $ ./configure
>>
>> + Problem/Error:
>> configure: error: installation or configuration problem: C++ compiler
>> cannot create executables.
>>
>> + Resolution:
>> $yum install gcc-c++
>>
>> --
>>
>> Multimedia and Communication | Property | Entertainment
>> Kwasi Owusu Gyasi - Agyei
>>
>> *cell*        (+27) (0) 76 466 4488
>> *website *www.4things.co.za
>> *email     *kwasi.gyasiagyei@4things.co.za
>> *skype    *kwasi.gyasiagyei
>> *role*        Developer.Designer.Software Architect
>> ------------------------------------------------------------------------
>>  VPRO   www.vpro.nl
>> ------------------------------------------------------------------------
>>
>


-- 

Multimedia and Communication | Property | Entertainment
Kwasi Owusu Gyasi - Agyei

*cell*        (+27) (0) 76 466 4488
*website *www.4things.co.za
*email     *kwasi.gyasiagyei@4things.co.za
*skype    *kwasi.gyasiagyei
*role*        Developer.Designer.Software Architect

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message