incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: Date discrepancy on Futon status page.
Date Thu, 03 Nov 2011 15:23:56 GMT
Filipe fixed this now. Thanks for the report! :)

Cheers
Jan
-- 

On Nov 3, 2011, at 11:57 , JC de Villa wrote:

> Thanks Jan,
> 
> I put in the fix as you suggested and the date shows up correctly now.
> Should I still file a bug for it in JIRA?
> 
> One last quick question... do you ever sleep? I see you on the list at all
> hours :).
> 
> Thanks again, and thanks for the all the great work you guys have put into
> this database!
> 
> -- 
> JC de Villa
> 
> On Thu, Nov 3, 2011 at 6:38 PM, Jan Lehnardt <jan@apache.org> wrote:
> 
>> Hi JC,
>> 
>> the best place to report errors lie this is our bug tracking system:
>> 
>>   https://issues.apache.org/jira/browse/COUCHDB
>> 
>> It ensures we don't forget about this report. Emails sometimes get lost
>> in the mists of time :)
>> 
>> As for the particular issue. It looks like share/www/status.html is at
>> fault:
>> 
>> Line 59:
>> 
>>   var year = d.getFullYear(), month = d.getMonth(), day = d.getDate();
>> 
>> Date().getMonth() is zero-based, i.e. January is 0, February is 1 etc.
>> (Thanks
>> to Java's Date() and ECMA's reluctance to fix this :)
>> 
>> Changing the line to this should do the trick:
>> 
>>   var year = d.getFullYear(), month = d.getMonth() + 1, day = d.getDate();
>> 
>> If you could confirm this, I'm happy to commit the fix.
>> Cheers
>> Jan
>> --
>> 
>> 
>> 
>> On Nov 3, 2011, at 10:39 , JC de Villa wrote:
>> 
>>> Hi guys,
>>> 
>>> I just noticed something odd with my most recently complied couch. It's
>>> based off of commit 74613f5c413a3d10bec024bcac8fe9e7be10ac74.
>>> 
>>> Anywho, I fired off a couple of continuous pull replications last night.
>>> No problems there, and everything is peachy. This afternoon, I looked at
>>> the status page and it's updating just fine, no hiccups at all. Then I
>>> noticed that the "Started on" and "Last updated on" column have the right
>>> time, but the date is off by one month. The dates all show "2011-10-2"
>> for
>>> the Start column and "2011-10-3" on the last updated column.
>>> 
>>> I first thought that it might have been the system date/time set
>>> incorrectly getting reflected on it, but the system date/time is correct,
>>> and the logs also show the correct date.
>>> 
>>> Nothing special done with compiling it... I used libmozjs185-dev from the
>>> ubuntu natty repositories, and couchdb was configured with --prefix=/opt.
>>> Config files are symlinked to /etc as I've always done.
>>> 
>>> Anyway, here's a snip of a screenshot of the server time and the status
>>> page:
>>> 
>>> http://dl.dropbox.com/u/6654126/snapshot4.png
>>> 
>>> Any ideas?
>>> 
>>> --
>>> JC de Villa
>> 
>> 


Mime
View raw message