incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nils Breunese <N.Breun...@vpro.nl>
Subject View indexing won't complete
Date Wed, 12 Oct 2011 14:48:07 GMT
Hello all,

I'm in the process of upgrading a CouchDB 0.10.1 instance to 1.0.2. I've had to modify some
map functions because of docs are sealed before being passed to map functions since 1.0.2.
I'm now trying to build our view indexes on 1.0.2, but the views for one design document won't
complete.

* All views in all design documents seem to build fine, except for one design document.
* CouchDB keeps restarting spontaneously when building the view index: "Apache CouchDB has
started on http://0.0.0.0:5984/" appears in the log, while I didn't restart it.
* Requesting the view again after a spontaneous restart normally resumes the view index build,
except that it stops doing that at some point. I currently have a view index that was checkpointed
until seq 536615, while the full db goes to 537234, and requesting the view after a restart
doesn't seem to do anything (no checkpoint logging, no high CPU usage). The .view file is
currently 5.2 GB, it's not finished yet and it won't resume.
* I can read the full _changes feed for this database successfully.

I've had some help from Robert Newson via IRC, but we haven't been able to get to the bottom
of this.

Any ideas? Should I give up on 1.0.2 and start over with 1.0.3 or 1.1.0?

Nils.
------------------------------------------------------------------------
 VPRO   www.vpro.nl
------------------------------------------------------------------------

Mime
View raw message