incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Kocoloski <kocol...@apache.org>
Subject Re: undefined reference to JS_SealObject
Date Mon, 24 Oct 2011 14:47:05 GMT
Ugh, that's really not good.  What version of CouchDB were you using?

Adam

On Oct 24, 2011, at 10:38 AM, CGS wrote:

> I remember I installed CouchDB using Spidermonkey from 'git clone git://github.com/membase/spidermonkey.git'
and it worked. I used that because the official version 1.8.5 raised similar error in CouchDB
compilation. Maybe it will help you as well.
> 
> Cheers,
> CGS
> 
> 
> 
> 
> On 10/24/2011 04:00 PM, Adam Kocoloski wrote:
>> Hi Jim, thanks for the reminder to update the instructions, 1.8.5 is definitely preferred
now.
>> 
>> Paul wrote most of the current logic to compile couchjs against various versions
of Spidermonkey in both CouchDB and BigCouch.  I don't know if he tried the Ubuntu 11.10 package
specifically.  I suspect when he's up later today he'll have some insight on the matter. 
Regards,
>> 
>> Adam
>> 
>> On Oct 24, 2011, at 9:51 AM, Jim R. Wilson wrote:
>> 
>>> My apologies if this is the wrong list for this kind of question.  I
>>> couldn't find a BigCouch specific mailing list.
>>> 
>>> I'm trying to build bigcouch for the first time (on Ubuntu 11.10 Oneiric).
>>> The instructions[1] say to use spidermonkey 1.9.2 and include steps on how
>>> to get this from ppa.
>>> 
>>> When I try to make, the build fails and I get this (followed by a bunch of
>>> similar errors):
>>> 
>>>    c++ -o build/couchjs -L/usr/lib/xulrunner-devel-2.0/lib
>>> build/main.o build/http.o  build/utf8.o build/util.o -lm -lpthread -lcurl
>>> -lnspr4 -lmozjs
>>>    build/main.o: In function `seal':
>>>    /tmp/bigcouch/couchjs/build/sm180.c:229: undefined reference to
>>> `JS_SealObject'
>>> 
>>> I found an email chain[2] suggesting that the problem is that this version
>>> of spidermonkey is too new for couchdb.
>>> 
>>> However, when I back out spidermonkey 1.9.2 and use the 1.8.5 version
>>> available through the normal apt channels, I get this:
>>> 
>>> 
>>> /usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib/libmozjs185-1.0.a
>>> (RegexCompiler.o):
>>> In function `JSC::Yarr::compileRegex(JSLinearString
>>>      const&, JSC::Yarr::RegexPattern&)': (.text+0x26ca): undefined
>>> reference to `PR_AtomicDecrement'
>>> 
>>> Any help is appreciated, thanks in advance.
>>> 
>>> [1] https://github.com/cloudant/bigcouch
>>> [2] http://permalink.gmane.org/gmane.comp.db.couchdb.user/15583
>>> 
>>> -- Jim R. Wilson (jimbojw)
> 


Mime
View raw message