incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin R. Coombes" <kevin.r.coom...@gmail.com>
Subject "%2F" problems
Date Fri, 16 Sep 2011 21:40:28 GMT
I am trying to replicate a couch database from one Windows machine to 
another.  Replication halts with an error when it gets to an attachment 
of the design document.  The error message in the (local) log file just 
before the stack dump says

[Fri, 16 Sep 2011 21:22:57 GMT] [error] [<0.813.0>] streaming att. ended 
but more data requested {1316,208177,498001}
[Fri, 16 Sep 2011 21:22:57 GMT] [info] [<0.813.0>] request for 
"_design%2Fbasic/docs.html" timed out, retrying in 0.5 seconds

The replication was started by sending a POST to the local machine; I am 
using pull replication from a remote source to the local target. Admins 
are set up on the local machine, and I provided the admin credentials 
both as part of the URL starting the replication and as part of the 
target URL.

When I use "curl" from the command line on the local machine to request 
a file from the remote machine, the command
     curl [REMOTEDB]/_design%2Fbasic/docs.html
returns nothing, while the command
     curl [REMOTEDB]/_design/basic/docs.html
returns the correct file.

Clearly, there is something about the encoding of a forward slash as a 
"%2F" that is confusing both me and at least one of the couch instances 
involved in this attempt at replication.

Can someone tell me [1] what is the underlying source of the problem? 
and [2] how do I persuade couch to just replicate the design documents 
properly?

Thanks,
     Kevin



Mime
View raw message