incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Hewitt <>
Subject Building from source, building SpiderMonkey, "configure: error: Could not find the js library."
Date Tue, 23 Aug 2011 15:15:52 GMT
Hi all,

I've been struggling to bring up CouchDB on a new server running CentOS 6.

I've installed Spidermonkey from source using the instructions at
but get the error:

configure: error: Could not find the js library.
Is the Mozilla SpiderMonkey library installed?

I have in /usr/local/lib64 and have tried 

./configure --with-erlang=/usr/lib64/erlang/usr/include --with-js-lib=/usr/local/lib64

But still get the error.

The Wiki page mentions the --with-js-include option, but I'm not sure what it's looking for,
so not sure what value to use for this option.

I can't install js-devel from yum because it requires version 5.8.8 of perl and I've got 5.10.1
(and have spent 12 hours trying to piece together a 5.8.8 install to no avail).

I had no errors when compiling Spidermonkey.

Any help would be hugely appreciated.


View raw message