incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Cottlehuber <d...@muse.net.nz>
Subject Re: Futon Test Suite Failures [CouchDB 1.1.0 / Windows 7 Home]
Date Thu, 14 Jul 2011 10:01:08 GMT
> On 13/07/2011 10:02 PM, Dave Cottlehuber wrote:
>>>
>>> On 12/07/2011 5:26 PM, Sam Kearns wrote:
>>>>
>>>> Hi Dave,
>>>>
>>>> Thanks for your response! I will send my couch.log directly to you via
>>>> e-mail.
>>>>
>>>> Cheers,
>>>> Sam

Hi Sam,

Thanks for sending those logs through. It's better to use dropbox,
pastie or similar for anything more than a snippet, as some people on
this list are hanging off 3G modems in Thailand.

I can still see cookies in your cache however - so not everything's
being cleared out. Dirty cache does make re-running the test suite for
attachments etc fail.

         {'Cookie',"5984_recent=_users%2Cvending;
AuthSession=c2FtS2Vhcm5zOjRFMUI4RDk2Orc5gNIknc94W66nFmIsoEiRhWCu"},

Anyway, it looks like some sort of failure in erlang at this point but
I'm guessing without some more info. Would you mind checking a few
things please?

- is there an erl_crash.dump file sitting anywhere, usually in %COUCHDIR%/bin.

- does erl.exe have the same failure? from a command prompt, with a
decent buffer history set (layout tab ,
http://commandwindows.com/configure.htm)

   set erl=erl
   couchdb.bat

then clear caches, run tests etc what happens? not worried about logs
at this point just did the erlang VM die or not. And if you can
capture the last few lines in the command prompt as it dies, that
would be great.

- does this happen with 1.1.0 and R14B01 ? Here's an equivalent 1.1.0
bundle using R14B01 + some relevant patches http://db.tt/FxbpIJA

Can you install this to a different directory (no service needed) and
then run through the same rigmarole again please,  both with erl.exe
and werl.exe? No logs reqd again, just whether the console craps out.

A couple of other questions so I can set up a test env if needed -
Do you have any other ssleay32.dll or libeay32.dll files in your path?
What visual c++ runtimes do you have installed (appears in add/remove proggies)?

Thanks

cheers
Dave

Mime
View raw message