incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Thomas <7za...@gmail.com>
Subject couchdb 1.1, couchdb lucene, include_docs=true
Date Tue, 07 Jun 2011 05:35:41 GMT
Hi all,

Having trouble with couchdb 1.1 together couchdb lucene 0.6 and using 
the include_docs=true parameter.  It was working fine with couchdb 1.0.x


When I do this GET to a lucene view and use include_docs=true:

http://localhost:5984/test/_fti/_design/test/by_path?q=kind:image&include_docs=true

I get this error:

{
   code: 500
   reason: "{"error":"bad_content_type","reason":"Content-Type must be 
application/json"} "
}

When I leave include_docs off, it works fine:

http://localhost:5984/test/_fti/_design/test/by_path?q=kind:image

{
     q: "kind:image",
     etag: "1224e617cb465190",
     skip: 0,
     total_rows: 2,
     search_duration: 2,
     fetch_duration: 9,
     rows: [
         {
             id: "116684826989320284f90c4cf472b94e",
             score: 1,
             fields: {
                 kind: "image",
                 name: "140.jpg",
                 width: "764",
                 height: "1068",
                 size: "255031"
             }
         },
         {
             id: "116684826989320284f90c4cf4013143",
             score: 1,
             fields: {
                 kind: "image",
                 name: "93.jpg",
                 width: "656",
                 height: "836",
                 size: "47173"
             }
         }
     ]
}


I've tried setting "Content-Type" header to "application/json" (via 
Apache HttpClient), but still get this error.  Same result via a browser.
It was working fine in 1.0.x

Could someone help?

Thanks,
Gary

Mime
View raw message