incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevor Bain <trevor.b...@gmail.com>
Subject Re: Macports OSX issues?
Date Thu, 07 Apr 2011 19:42:48 GMT
> You can also recompile Erlang with the necessary switch. It's quite simple -
the same thing happened to me a
> number of weeks ago. I can no longer remember exactly what's needed, but it's
definitely in the archives of
> this list.
> 
> 	/ Peter
> 
> > It's because the new version of Erlang that is installed with Mac
> > Ports does not work with the current version of CouchDB. You need to
> > downgrade Erlang to the previous version.
> > 
> > Owen


Great - thanks!

Someone, recently, opened up a similar ticket to this in macports (for the
erlang version error) and it was closed as fixed. So, I assumed that this wasn't
the error (bad assumption). I guess the same problem happened again more
recently - doesn't macports allow for build/runtime dependencies against
specific versions?

BTW this was super annoying to debug - could I have, somehow, attached an erl
terminal to couchdb to see what was going on?

Thanks,
Trevor


Mime
View raw message