incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Clement Hallet <clem...@challet.eu>
Subject Re: Debian package
Date Fri, 22 Apr 2011 08:33:08 GMT
Hi Jens

CouchDB 0.11.0 have been installed on our server through the Debian packages.
We got a basic use of CouchDB so i can't really tell you what are missing.

I just would like to add that in the current package, there is a dependency bug with jQuery
which leads to Futon to not work.
If you want to run Futon, jQuery has to downgraded from 1.5.1 to 1.4.2.
Is seems to be the same on the Ubuntu package : https://bugs.launchpad.net/ubuntu/+source/couchdb/+bug/716237

-- 
Clément

Le 22 avr. 2011 à 02:16, Jens Rantil a écrit :

> Hi,
> 
> I am considering deploying CouchDB on a Debian system.
> 
> I have noticed that the Debian package for CouchDB is rather old [1]. The
> latest package version contains CouchDB 0.11.0 and currently there is a
> security patch that is still to be added to the package[2]. My question is
> really, would you recommend using 0.11.0 for production use? I mean, it is
> included in Debian stable. Or, are there alternative ways to create a Debian
> package for later versions of CouchDB? Or is a later package hosted on an
> alternative repository?
> 
> To speed up the process to get the Debian package up to par with the
> latest/later CouchDB release(s), maybe the Ubuntu package[3] could used as a
> template?
> 
> [1] http://packages.qa.debian.org/c/couchdb.html
> [2] http://security-tracker.debian.org/tracker/source-package/couchdb
> [3] https://launchpad.net/ubuntu/+source/couchdb
> 
> I'd be grateful if anyone has any tips on deploying on a Debian system.
> 
> Thanks,
> Jens


Mime
View raw message