incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Gable <ziggythehams...@gmail.com>
Subject Re: lucene and "missing attachments"
Date Fri, 11 Feb 2011 21:27:59 GMT
I don't know if you have the patience or not, but you could convert  
the attachment XML document to JSON and store it as a property.

Is your indexing function checking for doc.attachments and that it has  
a length greater than zero?



On Feb 11, 2011, at 3:00 PM, Kristian Rink <kawazu428@googlemail.com>  
wrote:

> Folks;
>
> having running couchdb 1.0.1 (Ubuntu 10.10) and a recent build of
> couchdb-lucene, I am having trouble to do attachment full text
> indexing. Running the sample code provided with the couchdb-lucene
> README, I continuously end up with an error just alike this:
>
> {"error":"not_found","reason":"Document is missing attachment"}
>
> Googling the web, I found just few information on that, mostly telling
> that it might be caused by a couchdb version too old for the
> couchdb-lucene extension. Could this also be my specific case, or  
> might
> there be other issues causing this problem? Attachments in question
> aren't around for every document in my database, but, if there's an
> attachment, then it's a content.xml filled with meta-information (RDF)
> as provided by aperture framework... Can't really provide any more log
> output on that as there is none... :)
>
> TIA for any hints on that,
> Kristian

Mime
View raw message