incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Barnes <mrtr...@gmail.com>
Subject Odd replication failures on 0.11
Date Tue, 08 Feb 2011 05:48:59 GMT
I have been getting this error when I try to replicate databases:

Replication failed: {bad_term,{couch_rep_reader,'-open_doc_revs/3-fun-1-',
                             [{[{<<"error">>,<<"unauthorized">>},
                                {<<"reason">>,
                                 <<"You are not authorized to access 
this db.">>}]},
                              {http_db,"http://admin:******@(source 
server):5984/(database)/",
                                       [],[],
                                       [{"User-Agent","CouchDB/0.11.0"},
                                        {"Accept","application/json"},
                                        {"Accept-Encoding","gzip"}],
                                       [],get,nil,
                                       [{response_format,binary},
                                        {inactivity_timeout,30000}],
                                       10,500,nil}]}}

I'm logged in as the administrative user, and using the administrative 
credentials on the source database. (pull replication)

Replication starts running, and works for a quite a while before this 
occurs. (It seems similar in length to the amount of time one has in 
futon before being auto-logged-off)

I notice that I don't get this error if I replicate a database that 
doesn't restrict read access.

Is this: a) A known problem? and b) A problem that is fixed in 1.0.1?

Regards,

-Patrick

Mime
View raw message