incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Farrell <gsf...@gmail.com>
Subject Re: Can't get user:password@domain auth to work...
Date Mon, 08 Nov 2010 15:37:02 GMT
Did you set up an admin account? See
http://wiki.apache.org/couchdb/Setting_up_an_Admin_account . You can
also set one up through Futon by clicking "Fix this" in the
bottom-right corner.

On Mon, Nov 8, 2010 at 1:24 AM, Doug <douglas.linder@gmail.com> wrote:
> I've been trying to use the user:password@domain method for doing admin
> actions, but it doesn't seem to work.
>
> I get a response like this:
>
>   1> [info] [<0.10652.0>] 127.0.0.1 - - 'PUT' /hello 302
>
> 1> [debug] [<0.10654.0>] 'PUT'
> /_utils/session.html?return=%2Fhello&reason=You%20are%20not%20a%20server%20admin.
> {1,
>
>
>            1}
>
> Headers: [{'Accept',"text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2"},
>
>          {'Cache-Control',"no-cache"},
>
>          {'Connection',"keep-alive"},
>
>          {'Content-Length',"0"},
>
>          {'Content-Type',"application/json"},
>
>          {'Host',"localhost:5984"},
>
>          {'Pragma',"no-cache"},
>
>          {'User-Agent',"Java/1.6.0_22"}]
>
> 1> [debug] [<0.10654.0>] OAuth Params: [{"return","/hello"},{"reason","You
> are not a server admin."}]
>
> 1> [info] [<0.10654.0>] 127.0.0.1 - - 'PUT'
> /_utils/session.html?return=%2Fhello&reason=You%20are%20not%20a%20server%20admin.
> 405
>
> 1> [debug] [<0.10654.0>] httpd 405 error response:
>
>  {"error":"method_not_allowed","reason":"Only GET,HEAD allowed"}
>
> Is there some config option that has to be enable for this to work?
>
> ~
> Doug.
>

Mime
View raw message