incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Volker Mische <volker.mis...@gmail.com>
Subject Re: couchdb 1.0.0 with ubuntu 10.4
Date Fri, 16 Jul 2010 14:29:25 GMT
On 16.07.2010 14:31, Michael wrote:
> On Fri, Jul 16, 2010 at 8:14 AM, Volker Mische<volker.mische@gmail.com>wrote:
>
>> Servus Wolfgang,
>>
>>
>> On 07/16/2010 01:18 PM, Wolfgang Egger wrote:
>>
>>> Servus
>>> I'm not able to get couchdb 1.0.0 running correct under ubuntu 10.4.
>>>
>>> While installing I got an error bout a missing package mozjs that I'm
>>> ignoring
>>> (after reading some Web-Articles about that).
>>>
>>
>> You shouldn't ignore that error. Have a look at the "Installing on Ubuntu"
>> wiki page [1]. What you probably need it while ./configure is:
>> ./configure --with-js-lib=/usr/lib/xulrunner-devel-1.9.2.6/lib
>> --with-js-include=/usr/lib/xulrunner-devel-1.9.2.6/include
>>
>> I suggest running it without installing it first. Do a "make dev" and then
>> a:
>> LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.2.6 ./utils/run
>>
>> Now try to run the test suite in Futon.
>>
>> In case you have a not recently updated Ubuntu 10.4 use "xulrunner-1.9.2.3"
>> instead.
>>
>> [1] http://wiki.apache.org/couchdb/Installing_on_Ubuntu
>>
>> Cheers,
>>   Volker
>>
>
> Volker;
>
> Have you gotten CouchDB running on 10.4? I too spent most of yesterday
> trying to get couch installed right and have the same issues as Wolfgang.
> Couchdb installs (without errors, I did put in the xulrunner jslib) and when
> I start it there is no response. I just tried the make dev version and
> still, same thing, no luck.
>
> The logs files have been created, but there is nothing in them. I have in
> the root's home directory couchdb.stderr and couchdb.stdout. There is
> nothing in stdout, but stderr has:
>
> heart_beat_kill_pid = 22247
> heart_beat_timeout = 11
>
> Really stumped on this. I had every intention yesterday of getting this
> installed and creating a .deb package, but now I will just be happy to get
> it properly running.
>
> Any guesses?
>
> Thanks,
>
> Michael
>
Hi Micheal,

yes I have 1.0 installed on 10.4, though only on an outdated one (with 
xulrunner 19.2.3), and I have already helped a lot of people to get it 
run. So it should really work.

Try again to run it with ./utils/run, but set the log level to "debug" 
(in the couchsrcdir/etc/couchdb/local_dev.ini). And paste the output to 
some pastebin and post a link. BTW: the CouchDB IRC channel is also very 
helpful.

Cheers,
   Volker


Mime
View raw message