incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Hammond <skippy.hamm...@gmail.com>
Subject Re: DELETE not working in Windows Version of 0.11
Date Wed, 09 Jun 2010 08:15:20 GMT
This is a known problem on Windows and in theory should be fixed before 
the next release.  If you are lucky, simply sleeping a very short time 
and retrying will work - but if you are unlucky you may need to restart 
couchdb before the DB can be deleted.

Cheers,

Mark

On 8/06/2010 6:12 PM, Moritz Post wrote:
> Hello Couch People
>
> I am having a serious problem with CouchDB under windows. While running a
> serious of integration tests i have come to a scenario which fails under
> Windows.
>
> The Testsystem that fails is Win7 64bit and CouchDB 0.11.0 installed from
> the installer. I have reproduced the problem under two different Win7
> systems. The problem does not occure on a Mac running CouchDB 0.11.0.
>
> The following scenario leads to a responds 500 on the last delete statement.
> Its a series of tests steps to test for the creation of documents and the
> functionallity of the view "getDocuments". All other responds code up until
> the very last are correct.
>
> The DELETE operation of the last statement does delete all the documents in
> the database but does not drop the database itself. As you can see though...
> throughout the code DELETE operation did work (Line 5)
>
> 1>  [info] [<0.247.0>] 127.0.0.1 - - 'DELETE' /database 404
> 1>  [info] [<0.1294.0>] 127.0.0.1 - - 'PUT' /database 201
> 1>  [info] [<0.1295.0>] 127.0.0.1 - - 'GET' /database/ 200
> 1>  [info] [<0.1295.0>] 127.0.0.1 - - 'PUT' /database/_design/tpas 201
> 1>  [info] [<0.1302.0>] 127.0.0.1 - - 'DELETE' /database 200
> 1>  [info] [<0.1303.0>] 127.0.0.1 - - 'DELETE' /database 404
> 1>  [info] [<0.1304.0>] 127.0.0.1 - - 'PUT' /database 201
> 1>  [info] [<0.1305.0>] 127.0.0.1 - - 'GET' /database/ 200
> 1>  [info] [<0.1305.0>] 127.0.0.1 - - 'PUT' /database/_design/tpas 201
> 1>  [info] [<0.1312.0>] 127.0.0.1 - - 'GET'
> /database/_design/mydesign/_view/getDocuments?limit=1&descending=true 200
> 1>  [info] [<0.1312.0>] 127.0.0.1 - - 'POST' /database/ 201
> 1>  [info] [<0.1314.0>] checkpointing view update at seq 2 for database
> _design/mydesign
> 1>  [info] [<0.1312.0>] 127.0.0.1 - - 'GET'
> /database/_design/mydesign/_view/getDocuments?limit=1&descending=true 200
> 1>  [info] [<0.1314.0>] Shutting down view group server, monitored db is
> closing.
> 1>  [info] [<0.1313.0>] 127.0.0.1 - - 'DELETE' /database 500
>
> I hope anybody is able to tell me what i am doing wrong since this is a
> serious show stopper for our product.
>
> Thanks
> Moritz Post
>


Mime
View raw message