incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From faust 1111 <faust...@gmail.com>
Subject Re: Problem with Ubuntu, new xulrunner lib
Date Thu, 15 Apr 2010 22:09:11 GMT
Try
edit
/etc/ld.so.conf.d/xulrunner.conf
  /usr/lib/xulrunner-1.9.1.9/
  /usr/lib/xulrunner-devel-1.9.1.9/

ldconfig
and then reinstall couch



2010/4/16 Julian Moritz <mailings@julianmoritz.de>:
> Hi,
>
> I've had couchdb running under ubuntu, but not with the libmozjs-dev
> package installed, but configured with xulrunner. With version 1.9.1.8
> it worked all fine, but with the new version 1.9.1.9 of xulrunner,
> couchdb is crashing running the test suite:
>
>
> [Thu, 15 Apr 2010 21:25:25 GMT] [error] [<0.11281.0>] OS Process Error
> <0.14317.0> :: {os_process_error,{exit_status,127}}
>
> [Thu, 15 Apr 2010 21:25:25 GMT] [error] [<0.11281.0>] OS Process Error
> <0.14320.0> :: {os_process_error,{exit_status,127}}
>
> I've already deleted all couchdb-related stuff and reinstalled it, but
> it doesn't work, still got the error above.
>
> I'm running for installation
>
> D_RUN_PATH=/usr/lib/xulrunner-1.9.1.9/
> ./configure --with-js-lib=/usr/lib/xulrunner-devel-1.9.1.9/lib/
> --with-js-include=/usr/lib/xulrunner-devel-1.9.1.9/include
>
> make
>
> sudo make install
>
> What can I do now?
>
> Regards
> Julian
>

Mime
View raw message