incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Smythe <xkeita...@gmail.com>
Subject Re: Dependency problem while installing the new CouchDB-0.11.0 (libmozjs-dev)
Date Tue, 20 Apr 2010 22:41:25 GMT
Bharat, looks like the specific libs you're looking for are from libicu-3.6,
don't know if they're in 3.8:

libicu-3.6-5.11.4.x86_64 : International Components for Unicode - libraries
Repo        : cent-current
Matched from:
Filename    : /usr/lib64/libicudata.so.36



libicu-3.6-5.11.4.i386 : International Components for Unicode - libraries
Repo        : cent-current
Matched from:
Filename    : /usr/lib/libicudata.so.36



libicu-3.6-5.11.4.x86_64 : International Components for Unicode - libraries
Repo        : installed
Matched from:
Filename    : /usr/lib64/libicudata.so.36



libicu-3.6-5.11.4.i386 : International Components for Unicode - libraries
Repo        : installed
Matched from:
Filename    : /usr/lib/libicudata.so.36


On Tue, Apr 20, 2010 at 3:07 PM, Bharat <bharat.kjsce@gmail.com> wrote:

> I decided to manually install curl-7.20 and then build the rpm but while
> installing this rpm, I am getting following errors:
>
> [root@]# rpm -i couchdb-0.11.0-0.x86_64.rpm
> error: Failed dependencies:
> libicudata.so.36()(64bit) is needed by couchdb-0.11.0-0.x86_64
> libicui18n.so.36()(64bit) is needed by couchdb-0.11.0-0.x86_64
> libicuuc.so.36()(64bit) is needed by couchdb-0.11.0-0.x86_64
>
> I even tried installing curl-7.20 on the host but no luck. I have icu,
> libcurl-devel, lib-icu etc
>
> [root@]# rpm -qa | grep icu
> libicu-3.8-6.fc8
> libicu-3.8-6.fc8
> icu-3.8-6.fc8
> libicu-devel-3.8-6.fc8
> libicu-devel-3.8-6.fc8
>
> Did anyone manage to build an rpm out of 0.11?
>
> On Tue, Apr 20, 2010 at 12:33 PM, Dan Smythe <xkeitarox@gmail.com> wrote:
>
> > So, here's an interesting tidbit.
> >
> > If the -static flag is present during the spidermonkey configure tests,
> > they
> > fail. So,
> >
> >  -- RHEL ( nor EPEL ) have curl-7.18.0 available for RHEL5, so you have
> to
> > force it in (breaking numerous dependencies ) to have a chance with
> CouchDB
> > 0.11.
> >
> >  -- Trying to statically compile CouchDB 0.11 fails, because the
> > spidermonkey ./configure tests fail with the -static flag present.
> >
> > Therefore, it seems you can only get CouchDB 0.11 running on RHEL5 if
> > you're
> > OK with breaking any curl dependencies, which I'm not, because it's a
> long
> > list and includes php-*.
> >
> > I'm convinced that CouchDB 0.11 isn't going to fly on RHEL5 at this
> point.
> >
> > Anyone manage to do so, with spidermonkey, and without breaking curl
> > dependencies?
> >
> > Cheers~
> >
> >
> > On Tue, Apr 20, 2010 at 11:36 AM, Dan Smythe <xkeitarox@gmail.com>
> wrote:
> >
> > > Same thing here Bharat. I'm working on trying to build the RPM with a
> > > force-installed curl-devel 7.18 RPM I whipped up, hoping to compile
> > CouchDB
> > > statically against it so I don't have to mess with curl ( and all the
> > other
> > > dependencies ) on my numerous other hosts. I just can't get this
> > > spirdermonkey thing worked out.
> > >
> > > I'm doing this on a RHEL5 VM, with a snapshot prior to working, so
> > if/when
> > > I bust anything I can just revert back. I wouldn't suggest taking this
> > path
> > > on a non-VM.
> > >
> > > Cheers~
> > >
> > >
> > > On Tue, Apr 20, 2010 at 11:27 AM, Bharat <bharat.kjsce@gmail.com>
> wrote:
> > >
> > >> I have a similar issue. I am also trying to build couchdb 0.11 rpm
> from
> > >> 0.11
> > >> source, 0.10 spec and init but since I am building on RHEL 5,
> > >> libcurl-devel
> > >> version cant go pass 7.15 and 0.11 needs atleast 7.18.
> > >>
> > >> any workarounds for that? I dont wanna download 7.18 source and
> upgrade
> > >> since this rpm needs to run on several machines and manually upgrading
> > all
> > >> the machines will be a big pain.
> > >>
> > >> Thanks!
> > >>
> > >> On Tue, Apr 20, 2010 at 11:17 AM, Nils Breunese <N.Breunese@vpro.nl>
> > >> wrote:
> > >>
> > >> > Did you look at the package that EPEL currently has in their
> > repository
> > >> for
> > >> > 0.10? That might have some clues? SRPM is here:
> > >> >
> > >>
> > http://download.fedora.redhat.com/pub/epel/5/SRPMS/repoview/couchdb.html
> > >> >
> > >> > I have done several CouchDB from source installs following the
> > >> instructions
> > >> > on http://wiki.apache.org/couchdb/Installing_on_RHEL5 for
> > dependencies.
> > >> > Not updated to 0.11 yet, though.
> > >> >
> > >> > HTH, Nils.
> > >> > ________________________________________
> > >> > Van: Dan Smythe [xkeitarox@gmail.com]
> > >> > Verzonden: dinsdag 20 april 2010 18:15
> > >> > Aan: user@couchdb.apache.org
> > >> > Onderwerp: Re: Dependency problem while installing the new
> > >> CouchDB-0.11.0
> > >> >     (libmozjs-dev)
> > >> >
> > >> > All --
> > >> >
> > >> > Trying to build an RPM out of CouchDB 0.11 and I'm running into a
> > >> similar
> > >> > issue. This is on a CentOS 5.4 box, and I've used the directions
> here:
> > >> >
> > >> >
> > >>
> >
> http://wiki.apache.org/couchdb/Installing_SpiderMonkey?action=show&redirect=InstallingSpiderMonkeyto
> > >> > get SpiderMonkey installed in /usr/local/spidermonkey.
> > >> >
> > >> > Once installed following the directions, I have
> > >> > /usr/local/spidermonkey/{bin,include,lib64} which contain the usual
> > >> files.
> > >> >
> > >> > My RPM configure line looks as such:
> > >> >
> > >> > %configure --with-erlang=%_libdir/erlang%_includedir \
> > >> >  --with-js-lib=/usr/local/spidermonkey/lib64 \
> > >> >  --with-js-include=/usr/local/spidermonkey/include
> > >> >
> > >> > Yet still it refuses to locate the libraries:
> > >> >
> > >> > /*snip*/
> > >> > checking for pthread_create in -lpthread... yes
> > >> > checking for JS_NewContext in -lmozjs... no
> > >> > checking for JS_NewContext in -ljs... no
> > >> > checking for JS_NewContext in -ljs3250... no
> > >> > checking for JS_NewContext in -ljs32... no
> > >> > configure: error: Could not find the js library.
> > >> >
> > >> > Is the Mozilla SpiderMonkey library installed?
> > >> > error: Bad exit status from /var/tmp/rpm-tmp.2894 (%build)
> > >> >
> > >> >
> > >> > RPM build errors:
> > >> >    Bad exit status from /var/tmp/rpm-tmp.2894 (%build)
> > >> > /*snip*/
> > >> >
> > >> > I have tried a number of different times and methods. The js-devel
> > >> package
> > >> > is installed as well. Furthermore, I've tried to set the
> > LD_LIBRARY_PATH
> > >> > and
> > >> > LD_INCLUDE_PATH, all to no avail.
> > >> >
> > >> > Anyone have any ideas? I've started from the ground up twice now and
> > am
> > >> > running out of patience.
> > >> >
> > >> > Cheers~
> > >> >
> > >> > --Dan
> > >> >
> > >> > De informatie vervat in deze  e-mail en meegezonden bijlagen is
> > >> uitsluitend
> > >> > bedoeld voor gebruik door de geadresseerde en kan vertrouwelijke
> > >> informatie
> > >> > bevatten. Openbaarmaking, vermenigvuldiging, verspreiding en/of
> > >> verstrekking
> > >> > van deze informatie aan derden is voorbehouden aan geadresseerde.
De
> > >> VPRO
> > >> > staat niet in voor de juiste en volledige overbrenging van de inhoud
> > van
> > >> een
> > >> > verzonden e-mail, noch voor tijdige ontvangst daarvan.
> > >> >
> > >>
> > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message