incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randall Leeds <randall.le...@gmail.com>
Subject Re: Pull replication fails with 404
Date Wed, 31 Mar 2010 20:34:14 GMT
Could you turn on debug logging and provide what you can of the log
during replication if there is no sensitive information?

On Wed, Mar 31, 2010 at 13:23, Craig Blake <craigb@compasspointtech.net> wrote:
> Sorry, to be clear I am trying to replicate an entire database, but the replication fails
with the error about a missing "_local" doc.  The database name is "mydb-prod" and accessed
through an Apache front-end using ProxyPass (and ReverseProxyPass), where "/data" is the context
path to the CouchDB database root.
>
> The proxying seems to be working fine for accessing documents and views, replication
is the only thing that is not working for me.
>
> Hope that's more clear.
>
> Thanks,
> Craig
>
> On Mar 31, 2010, at 2:54 PM, Robert Newson wrote:
>
>> Yes, they should be ignored. I thought you were trying to read a
>> _local document on the "other" replica, and was just confirming that
>> the doc didn't get replicated (hence the 404).
>>
>> Re-reading your original message, is it just that you're not %2F
>> escaping the / in your database name? I'm assuming the db is called
>> "data/mydb-prod"?
>>
>> B.
>>
>> On Wed, Mar 31, 2010 at 6:46 PM, Craig Blake
>> <craigb@compasspointtech.net> wrote:
>>> Shouldn't a replication of the database ignore them?  Or is there a step I need
to do to filter those docs out explicitly?
>>>
>>> Thanks,
>>> Craig
>>>
>>> On Mar 31, 2010, at 11:42 AM, Robert Newson wrote:
>>>
>>>> _local documents are not replicated. They're used for tracking things
>>>> that are local, like replication checkpoints.
>>>>
>>>> B.
>>>>
>>>> On Wed, Mar 31, 2010 at 4:13 PM, Craig Blake
>>>> <craigb@compasspointtech.net> wrote:
>>>>> I am trying to do a pull replication from a remote database to a local
database (that was previously pushed to the remote) but it fails with a 404:
>>>>>
>>>>> "The requested URL /data/mydb-prod/_local/4d0453abc08950ad3ddf643d116b3a08
was not found on this server."
>>>>>
>>>>> I haven't found much mention of what "_local" docs are or why one would
be expected that is not there, either on the mailing list or in the Couch book.  I am using
0.11 for both DB instances.
>>>>>
>>>>> Any ideas on what I've done wrong?
>>>>>
>>>>> Thanks,
>>>>> Craig
>>>
>>>
>
>

Mime
View raw message