incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Anderson <>
Subject Re: filters for _changes dont seem to work
Date Sun, 29 Nov 2009 19:05:31 GMT
On Sun, Nov 29, 2009 at 9:39 AM, Sven Helmberger <> wrote:
> wrote:
>> Sven Helmberger wrote:
>>> You are not writing back documents with the same content, are you?
>> No I am not. I am sending changes. What is particularly strange is that it
>> seems to work a few times and then stop working. Its not like it sometimes
>> works and sometimes doesnt. Its always a pattern of first working and then
>> not working. Once the filter stops being called, it doesnt get seem to be
>> called again until I do an add document. Then the filter will again be
>> called a few times on updates and then stop workign again..

To be clear, the _changes API doesn't guarantee that you'll get every
single change. If a document is changed many times in quick succession
it's possible that only the latest state will appear in the _changes
feed. This could be part of what you are seeing. (depending on if you
are editing lots of documents or editing a few docs lots of times).

Anything you can do to make this more reproducible (script, JS test,
etc) would be extremely helpful for debugging.


>> Stephen
>> ____________________________________________________________
>> Diet Help
>> Cheap Diet Help Tips. Click here.
> I was just speculating that CouchDB might decide not call the filter
> function for a known document content.
> Regards,
> Sven Helmberger

Chris Anderson

View raw message