incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Senthilkumar Peelikkampatti <senthilkumar.peelikkampa...@gmail.com>
Subject Re: Snow Leopard and Spidermonkey not working
Date Wed, 04 Nov 2009 06:37:47 GMT
After deleting the /opt/local/lib/libjs.dylib and symlink from
/usr/local/lib/libjs.dylib it worked. I think my path was skewed.
Thanks.

On Tue, Nov 3, 2009 at 11:54 PM, Senthilkumar Peelikkampatti <
senthilkumar.peelikkampatti@gmail.com> wrote:

> Making couchdb from source on Snow leopard failed with following error,
>
> ld: warning: in /opt/local/lib/libjs.dylib, file is not of required
> architecture
> Undefined symbols:
>   "_JS_GetStringBytes", referenced from:
>       _JSValToChar in couchjs-couch_js.o
>   "_JS_EvaluateUCScript", referenced from:
>       _EvalInContext in couchjs-couch_js.o
> .
> .
> .
> .
> .
> ld: symbol(s) not found
> collect2: ld returned 1 exit status
> make[4]: *** [couchjs] Error 1
> make[3]: *** [all-recursive] Error 1
>
> make[2]: *** [all-recursive] Error 1
> make[1]: *** [all-recursive] Error 1
> make: *** [all] Error 2
>
> I followed the instructions from
> http://wiki.apache.org/couchdb/Installing_on_OSX
>
> This is my file & otool result
>
> bash-3.2$ file /opt/local/lib/libjs.dylib
> /opt/local/lib/libjs.dylib: Mach-O dynamically linked shared library i386
> bash-3.2$ otool -L /opt/local/lib/libjs.dylib
> /opt/local/lib/libjs.dylib:
>     /opt/local/lib/libjs.dylib (compatibility version 0.0.0, current
> version 0.0.0)
>     /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current
> version 111.1.4)
>     /opt/local/lib/nspr/libplds4.dylib (compatibility version 1.0.0,
> current version 1.0.0)
>     /opt/local/lib/nspr/libplc4.dylib (compatibility version 1.0.0, current
> version 1.0.0)
>     /opt/local/lib/nspr/libnspr4.dylib (compatibility version 1.0.0,
> current version 1.0.0)
>     /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version
> 1.0.0)
>
> It looks like spidermonkey is built as 32 bit? Can anyone help me to
> address this issue?
>
>
>
> On Wed, Sep 2, 2009 at 9:06 PM, Justin Walgran <jwalgran@gmail.com> wrote:
>
>> A "sudo port install curl" cleared up the curl_rule issue.
>> -Justin
>>
>> On Wed, Sep 2, 2009 at 10:49 PM, Justin Walgran <jwalgran@gmail.com>
>> wrote:
>>
>> > I managed to get ./configure to complete by remembering to pass the
>> --with*
>> > switches.
>> > Now I have a curl error when I make couchdb
>> >
>> > gcc -DHAVE_CONFIG_H -I. -I../..   -L/usr/local/spidermonkey/lib
>> > -L/usr/local/lib -L/opt/local/lib -I/usr/local/lib/erlang/usr/include
>> > -I/usr/lib/erlang/usr/include -I/usr/local/lib/erlang/usr/include
>> > -I/opt/local/lib/erlang/usr/include -I/usr/local/spidermonkey/include
>> > -DXP_UNIX   -I/opt/local/include -g -O2 -MT couchjs-couch_js.o -MD -MP
>> -MF
>> > .deps/couchjs-couch_js.Tpo -c -o couchjs-couch_js.o `test -f
>> 'couch_js.c' ||
>> > echo './'`couch_js.c
>> > In file included from /opt/local/include/curl/curl.h:36,
>> >                  from couch_js.c:21:
>> > /opt/local/include/curl/curlrules.h:134: error: size of array
>> > ‘__curl_rule_01__’ is negative
>> > make[3]: *** [couchjs-couch_js.o] Error 1
>> > make[2]: *** [all-recursive] Error 1
>> > make[1]: *** [all-recursive] Error 1
>> > make: *** [all] Error 2
>> >
>> > Googling for the curl_rule_01 points to an issue with 64 bit but I am
>> > unsure how to resolve it.
>> >
>> > - Justin
>> >
>> >
>> >
>> > On Wed, Sep 2, 2009 at 10:28 PM, Justin Walgran <jwalgran@gmail.com
>> >wrote:
>> >
>> >> I have the same problem. From the couchdb source dir
>> >> $ ./configure
>> >> ...
>> >> ...
>> >> checking for JS_NewContext in -lmozjs... no
>> >> checking for JS_NewContext in -ljs... no
>> >> checking for JS_NewContext in -ljs3250... no
>> >> checking for JS_NewContext in -ljs32... no
>> >> configure: error: Could not find the js library.
>> >>
>> >> Is the Mozilla SpiderMonkey library installed?
>> >>
>> >> Following the will written instructions on the wiki [1] does not help.
>> >>
>> >> Have other snow leoparders built successfully from source?
>> >>
>> >> [1] http://wiki.apache.org/couchdb/Installing_on_OSX
>> >>
>> >>
>> >> On Wed, Sep 2, 2009 at 11:50 AM, Trevor Turk <trevorturk@gmail.com
>> >wrote:
>> >>
>> >>> The Spidermonkey part of these installation instructions don't work
>> for
>> >>> me:
>> >>>
>> >>> http://wiki.apache.org/couchdb/Installing_on_OSX
>> >>>
>> >>> $ sudo ranlib /usr/local/spidermonkey/lib/libjs.a
>> >>> ranlib: file: /usr/local/spidermonkey/lib/libjs.a(jslock.o) has no
>> >>> symbols
>> >>>
>> >>> Has anyone had luck with this? I don't know what to do.
>> >>>
>> >>> Thanks!
>> >>> - Trevor
>> >>>
>> >>
>> >>
>> >
>>
>
>
>
> --
> Regards,
> Senthilkumar Peelikkampatti,
> http://pmsenthilkumar.blogspot.com/
>
>


-- 
Regards,
Senthilkumar Peelikkampatti,
http://pmsenthilkumar.blogspot.com/

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message