incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Trevor Turk <trevort...@gmail.com>
Subject Re: Snow Leopard
Date Sat, 12 Sep 2009 18:28:19 GMT
I'm really not sure. Try just running sudo couchdb and see if  
everything works. If so, there must be a permissions issue. I'm not  
too good with this stuff, though, so at that point you might try the  
irc channel, or maybe someone will reply here. In any case, please  
report back! I'm sure there are more people having trouble than just  
us :)

- Trevor

On Sep 12, 2009, at 10:47 AM, Justin Walgran <jwalgran@gmail.com> wrote:

> Trevor,
> Well done! Thanks.
>
> After running through your steps, I can launch couchdb using './ 
> utils/run'
> however when I try 'sudo -i couchdb couchdb' I get nothing. No  
> crash, no
> console messages, nada. /usr/local/var/log/couchdb is empty.
>
> How can I find out what is choking the couchdb startup process?
>
> -Justin
>
>
>
> On Thu, Sep 10, 2009 at 11:45 PM, Trevor Turk <trevorturk@gmail.com>  
> wrote:
>
>> With the generous help of davisp in #couchdb, I was able to get
>> CouchDB working, it would seem, on Snow Leopard.
>>
>> I've done up some shoddy instructions on what I did here:
>>
>> http://pastie.org/613214
>>
>> The basics are installing everything from MacPorts, then uninstalling
>> the couchdb port (which doesn't seem to work quite right). Then, you
>> install couchdb from source, fix the permissions, and set it up to
>> startup on boot.
>>
>> I think this should all be fine, but feedback is more than welcome.
>>
>> Thanks!
>> - Trevor
>>

Mime
View raw message