incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arun Thampi <arun.tha...@gmail.com>
Subject Re: CouchDB Trunk - Not able to GET any document
Date Sat, 15 Aug 2009 00:54:42 GMT
On Fri, Aug 14, 2009 at 9:35 AM, Paul Davis <paul.joseph.davis@gmail.com>wrote:

> Arun,
>
> If you check erl -version the last triple should be the VM version.
>
> If your version is 5.6.2 then that equates to R12B2. For 5.x.y X is
> the number after R - 6 and Y is the number after B. So R13B1 is 5.7.1


Thanks Paul, didn't know about the mapping from erl -version to VM version.
Looks like upgrading to R12B5 did the trick. I was using R12B4 (5.6.4)
earlier and looks like R12B5 is a minimum requirement to run trunk?



>
>
> Paul
>
> On Thu, Aug 13, 2009 at 9:29 PM, Arun Thampi<arun.thampi@gmail.com> wrote:
> > On Fri, Aug 14, 2009 at 9:14 AM, Paul Davis <paul.joseph.davis@gmail.com
> >wrote:
> >
> >> Arun,
> >>
> >> Are you by chance on Erlang R12B3-4 or so? The re module was included
> >> around 2 or 3 and then changed rapidly until R12B5 which is the same
> >> as R13B AFAIK.
> >
> >
> > Thanks Paul. erlang:system_info(otp_release). says "12B" so that must be
> it.
> > I'm installing 12B5 now and hopefully that should fix it.
> >
> > Thanks again!
> >
> >>
> >>
> >> Is it just me or is a requirement bump to R12B5 getting closer and
> closer?
> >>
> >> Paul
> >>
> >> On Thu, Aug 13, 2009 at 9:10 PM, Arun Thampi<arun.thampi@gmail.com>
> wrote:
> >> > Hi guys - I just checked out the trunk version (r804007) and it
> installs
> >> > fine and boots up fine as well, but when I access either
> >> > http://localhost:5984/ or Futon (or any document/page), it gives me
> this
> >> > error:
> >> >
> >> > =ERROR REPORT==== 14-Aug-2009::09:00:35 ===
> >> > {mochiweb_socket_server,235,{child_error,undef}}
> >> > [error] [<0.202.0>] {error_report,<0.22.0>,
> >> >    {<0.202.0>,crash_report,
> >> >     [[{pid,<0.202.0>},
> >> >       {registered_name,[]},
> >> >       {error_info,
> >> >           {error,undef,
> >> >               [{re,split,
> >> >                    ["{couch_httpd_oauth,
> oauth_authentication_handler},
> >> > {couch_httpd_auth, default_authentication_handler}",
> >> >                     "(?<=})\\s*,\\s*(?={)",
> >> >                     [{return,list}]]},
> >> >                {couch_httpd,make_arity_1_fun_list,1},
> >> >                {couch_httpd,handle_request,5},
> >> >                {mochiweb_http,headers,5},
> >> >                {proc_lib,init_p,5}]}},
> >> >
> >> >
> >> > I'm on OS X 10.5.8.
> >> >
> >> > Any pointers will be much appreciated, thanks in advance!
> >> >
> >> > Cheers,
> >> > Arun
> >> >
> >> > --
> >> > It's better to be a pirate than join the Navy - Steve Jobs
> >> > http://mclov.in
> >> >
> >>
> >
> >
> >
> > --
> > It's better to be a pirate than join the Navy - Steve Jobs
> > http://mclov.in
> >
>



-- 
It's better to be a pirate than join the Navy - Steve Jobs
http://mclov.in

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message