incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <paul.joseph.da...@gmail.com>
Subject Re: Getting started with CouchDB.
Date Sun, 12 Jul 2009 21:28:08 GMT
On Sun, Jul 12, 2009 at 5:16 PM, patrick flaherty<patf@well.com> wrote:
>
> thanx Paul, that's very helpful.
>
> Unfortunately futon is not quite as helpful: the lower right tells me
> version 0.0.0.  Where else can I find the version number
> of my current CouchDB?  (I'm of course looking around elsewhere already).
>

The only thing I can suggest would be to look through the install
directory for the README or something that might specify the version.
The definitive place to check is acinclude.m4 but I haven't the
slightest what may or may be included by a Windows installer.

> Don't mind trying to build CouchDB for myself.  Have an up-to-date cygwin
> kit (and visual studio, etc) and have recently built
> both openssl and firefox on my XP SP2 machine so I don't feel too
> uncomfortable with building open source projects on windows.
>

As for build instructions I'd check the dev list for messages from Mark Hammond.

> pat
>
>
>
> Paul Davis wrote:
>>
>> Patrick,
>>
>> My first guess is that those Windows binaries are for CouchDB 0.8.x
>> and the tutorial you're following is referring to 0.9.x features.
>> Futon should tell you what version you're running in the bottom right
>> corner. The _show stuff is definitely 0.9.x only. If they are old
>> binaries, there's been quite a bit of work recently on getting a 0.9.x
>> installer going. I know there's a URL for build instructions on
>> windows around here somewhere but I'm not sure if they finished up a
>> full installer quite yet.
>>
>> HTH,
>> Paul Davis
>>
>> On Sun, Jul 12, 2009 at 4:41 PM, patrick flaherty<patf@well.com> wrote:
>>
>>>
>>> Hi,
>>>
>>> I do a good deal of database programming - very little web programming.
>>>  Am
>>> interested in CouchDB's database capabilities (as opposed to its
>>> web interface which is what's perhaps hanging me up at the moment).
>>>
>>> After I'd figured out a thing or two, successfully did the windows
>>> install
>>> from here:
>>>
>>> http://www.brunomlopes.com/software/couch-db-binaries
>>>
>>> (thanx to whoever created it - it works well).
>>>
>>> So I can go to futon and create databases, documents, etc.
>>>
>>> Then tried this 15-minute tutorial:
>>>
>>> http://wiki.apache.org/couchdb/CouchIn15Minutes
>>>
>>> It seems to have worked up till #6.  #6 is where you query from
>>> _design/render over to the ID of the document you created previously
>>> trying
>>> to invoke the 'greetings' property.  In my case that would be:
>>>
>>>
>>> http://localhost:5984/example/_design/render/_show/salute/25cedb097d37e389ca5763fe76a79007
>>>
>>> This fails with, as best I've been able to format it, the trace that
>>> follows:
>>>
>>> {"error":"EXIT":"reason":"{function_clause,
>>>  [{couch_httpd,handle_db_request,
>>>       [{mochiweb_request,#Port<0.2357>,'GET',
>>>
>>> \"\/example\/_design\/render\/%2225cedb097d37e389ca5763fe76a79007%22\",
>>>            {1,1},
>>>            {9,
>>>             {\"host\",
>>>              {'Host',\"localhost:5984\"},
>>>              {\"accept\",
>>>               {'Accept',
>>>
>>>
>>>  \"text\/html,application\/xhtml+xml,application\/xml;q=0.9,*\/*;q=0.8\"},
>>>               nil,
>>>               {\"accept-language\",
>>>                {'Accept-Language',\"en-us,en;q=0.5\"},
>>>                {\"accept-encoding\",
>>>                 {'Accept-Encoding',\"gzip,deflate\"},
>>>                 {\"accept-charset\",
>>>                  {'Accept-Charset',\"ISO-8859-1,utf-8;q=0.7,*;q=0.7\"},
>>>                  nil,nil},
>>>                 nil},
>>>                {\"connection\",{'Connection',\"keep-alive\"},nil,nil}}},
>>>              {\"user-agent\",
>>>               {'User-Agent',
>>>                   \"Mozilla\/5.0 (Windows; U; Windows NT 5.1; en-US;
>>> rv:1.9.2a1pre) Gecko\/20090708 Mozilla\/5.0 (Windows; U; Windows NT 6.0;
>>> en-US; rv:1.9.2a1pre) Gecko\/20090407 Minefield\/3.6a1pre
>>> AutoPager\/0.5.2.2
>>> (http:\/\/www.teesoft.info\/)\"},
>>>               {\"keep-alive\",{'Keep-Alive',\"115\"},nil,nil},
>>>               {\"x-autopager\",
>>>                {\"X-Autopager\",\"0.5.2.2
>>> (http:\/\/www.teesoft.info\/)\"},
>>>                nil,nil}}}}},
>>>        'GET',
>>>        {\"example\",<0.71.0>,
>>>
>>>  [\"_design\",\"render\",\"%2225cedb097d37e389ca5763fe76a79007%22\"]}]},
>>>   {couch_httpd,handle_request,2},
>>>   {mochiweb_http,headers,4},
>>>   {proc_lib,init_p_do_apply,3}]}"}
>>>
>>> The function would appear to be mal-formed and while I've tried all kinds
>>> of
>>> possibilities for rewriting it, I continue to get the above trace.
>>>
>>> I don't think the problem is browser dependent but tried two version of
>>> FF
>>> as well as IE 7.  And no go.  (one version, above, has AutoPager - the
>>> other version does not).
>>>
>>> Hope someone has some idea of what I might be doing wrong.
>>>
>>> pat
>>>
>>>
>>>
>>>
>>
>>
>>
>
>

Mime
View raw message