incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Anderson <jch...@apache.org>
Subject Re: Futon: badarg error...
Date Wed, 06 May 2009 14:56:14 GMT
On Wed, May 6, 2009 at 12:48 AM, Parnell Springmeyer <ixmatus@gmail.com> wrote:
> In attempting to access the futon administrative resource, I am encountering
> this error:
>
> {"error":"unknown_error","reason":"badarg"}
>
> In attempting to figure it out further, I turned on debug which gives me
> this:
>
> debug] [<0.53.0>] 'GET' /_utils/ {1,1}
> Headers:
> [{'Accept',"text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8"},
>         {'Accept-Charset',"ISO-8859-1,utf-8;q=0.7,*;q=0.7"},
>         {'Accept-Encoding',"gzip,deflate"},
>         {'Accept-Language',"en-us,en;q=0.5"},
>         {'Cache-Control',"max-age=0"},
>         {'Connection',"keep-alive"},
>         {'Host',"24.234.73.31:5984"},
>         {'Keep-Alive',"300"},
>         {'User-Agent',"Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5;
> en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10 FirePHP/0.2.4"}]
> [error] [<0.53.0>] Uncaught error in HTTP request: {error,badarg}
> [debug] [<0.53.0>] Stacktrace:
> [{erlang,universaltime_to_localtime,[{{1969,12,31},{23,59,59}}]},

it looks like your system clock is set to 1969. is that the case? does
fixing it help?

if not you might have discovered a bug in the Erlang std library.
seems unlikely so do try to set your clock and see if that helps.


>            {calendar,local_time_to_universal_time_dst,1},
>            {httpd_util,rfc1123_date,1},
>            {mochiweb_request,serve_file,4},
>            {couch_httpd,serve_file,3},
>            {couch_httpd,handle_request,4},
>            {mochiweb_http,headers,5},
>            {proc_lib,init_p_do_apply,3}]
> [debug] [<0.53.0>] httpd 500 error response:
> {"error":"unknown_error","reason":"badarg"}
>
> [info] [<0.53.0>] 24.234.73.31 - - 'GET' /_utils/ 500
>
> The server I have CouchDB running on is a FreeBSD server. I install Erlang
> 5.6.5 from ports and CouchDB 0.9.0 from ports as well. All other functions
> seem to work properly (although I haven't tested thoroughly).
>
> Ie: http://[domain]:5984:/_all_dbs/ works just fine, and so does CURL
> commands to create a database on the server... Futon is just throwing this
> unusable stack trace at me and I'm hoping somone with more experience and
> knowledge of the codebase or system could find that stack trace helpful.
>
> If there are other log/debug sources I can look at as well, please inform me
> - I would love to be able to use the Futon interface!
>



-- 
Chris Anderson
http://jchrisa.net
http://couch.io

Mime
View raw message