incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Deja <>
Subject Re: Only getting "eacces" after port install on Mac OS X
Date Sun, 26 Apr 2009 00:54:20 GMT

my couchdb directory looks exactly like yours:

drwxr-xr-x  5 couchdb  couchdb    170 26 Apr 02:41 couchdb

I also checked the other ini files, as You wrote. On a quick glance,  
they seemed correct. (No "/var", only "/opt" at least.) And since  
couchdb works for the root user (see other mail), I did not  
investigate further. However, I noticed that the ini files in /opt/ 
local/etc/couchdb and the folder itself belonged to root, so I changed  
the owner to couchdb:couchdb.

That did not work, too. At least, I can run couchdb as root now and do  
some testing and development. But on the long run, I need to run it  
with its own user of course.

Thanks once more and good night (at least in my timezone),

Am 26.04.2009 um 02:37 schrieb Paul Davis:

> Madoc,
> You'll also want to check /opt/local/etc/couchdb/ for more ini  
> files. Other things you'll want to check is that the write  
> permissions on /opt/local/lib/couchdb actually allow writes. It  
> should look something like:
> davisp@puny:~/Desktop$ ls -ld /usr/local/var/lib/couchdb/
> drwxr-xr-x 4 couchdb root 4096 2009-03-24 20:28 /usr/local/var/lib/ 
> couchdb/
> Except that it'd be /opt/local instead of /usr/local for ports.
> Other things to verify, can you stop the service and then just run  
> couchdb as root and see if it works?
> HTH,
> Paul Davis
> Matthias Deja wrote:
>> Hello Paul,
>> thanks for the quick response. You are correct about the location  
>> of couchdb on Mac OS. Unfortunately, the error stays the same on my  
>> system.
>> I ran the chown, which did not help. Also, I checked the config  
>> file under:
>> /opt/local/Library/LaunchDaemons/org.apache.couchdb.plist
>> (Is there another CouchDB init file anywhere?) - This file seems to  
>> contain all the right paths.
>> In order to find out if CouchDB runs under the right user, I did:
>> <<<
>> Nova:lib madoc$ ps -U couchdb
>>  622   ??  SNs    0:00.20 /System/Library/Frameworks/ 
>> CoreServices.framework/Frameworks/
>>  626   ??  Ss     0:00.76 /opt/local/lib/erlang/erts-5.6.5/bin/beam  
>> -Bd -K true -- -root /opt/loca
>> >>>
>> Looks oky to me.
>> I also restarted the service. But the error stays the same on my  
>> system.
>> By the way: The CouchDB lib directory (/opt/local/var/lib/couchdb)  
>> is empty, except for .turd_couchdb. Shall it be this way?
>> Thanks,
>> Madoc.
>> Am 26.04.2009 um 01:52 schrieb Paul Davis:
>>> Madoc,
>>> From what you describe it sounds very much like the couchdb user is
>>> unable to write to the lib directory. I'm not extensively familiar
>>> with the ports version, but you'll want to make sure that the lib
>>> directory is writable by the user running couchdb. I know you said
>>> that you changed the owner but some things to double check:
>>> My guess is that the couchdb lib directory for a port installed
>>> version is at /opt/local/lib/couchdb
>>> You need to make sure that this directory has write permissions for
>>> the user running couchdb. You might want to try something like:
>>>   $ sudo chown -R couchdb:couchdb /opt/local/lib/couchdb
>>> Also, you can check the ini files for the root directory to make  
>>> sure
>>> that the lib direcotry is /op/local/lib/couchdb if things are still
>>> broken. Also, you can double check that the beam process is  
>>> running as
>>> the couchdb user with top.
>>> Other than that, I haven't got many pointers, but seeing as couchdb
>>> starts and you can visit futon this definitely sounds like a weird
>>> permissions error.
>>> HTH,
>>> Paul Davis
>>> On Sat, Apr 25, 2009 at 7:36 PM, Matthias Deja  
>>> <> wrote:
>>>> Hello,
>>>> I installed CouchDB just a few minutes ago on my MacOS X 10.5  
>>>> system. As
>>>> documented in the CouchDB Wiki, I used "port" to install CouchDB.
>>>> CouchDB is started, and I can use Futon on my web browser.  
>>>> However, on all
>>>> tests from the test suite and when trying to create a database, I  
>>>> get an
>>>> "eacces" error message.
>>>> Probably the error is simple to solve, but I do not know how.  
>>>> Please help
>>>> me. I already tried rebooting (no manual starting of CouchDB was  
>>>> required,
>>>> because I installed it as a service), and I tried changing the  
>>>> owner of the
>>>> CouchDB log and lib directories to "couchdb". The error message  
>>>> stays the
>>>> same.
>>>> My knowledge of Unix is present, but very limited. However, if  
>>>> You tell me
>>>> which commands to enter, I will do so and send You the result.
>>>> Thanks very much!
>>>> Madoc.

View raw message