incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: Segmentation fault on PUT
Date Fri, 27 Feb 2009 10:16:27 GMT

On 27 Feb 2009, at 10:59, Tim Somers wrote:

> Hi Jan,
>
> Of course, I should have known you'd need all the details...
>
> I'm using debian squeeze (testing) with all updates. Just today,  
> erlang was
> updated to version "1:12.b.5-dfsg-2", I'm not sure which version was
> installed when the error occured.
> For couchdb, I'm using the trunk version from svn, the latest  
> revision is
> 747852.
> As for HIPE, I'm not even sure what it does. I'm using all default
> configuration values as checked out from svn, only the port has been  
> changed
> to 5985, to avoid conflicts with version 0.8.1 installed from debian.
> Finally, py-simplecouchdb is version 0.9.25.

Are you using a database that was created with 0.8.1 into the SVN  
version?
That's not going to work.

Cheers
Jan
--

>
> Thanks
> Tim
>
>
> On Fri, Feb 27, 2009 at 10:41 AM, Jan Lehnardt <jan@apache.org> wrote:
>
>> Hi Tim,
>>
>> thanks for the report. What is your operating system? Which Erlang
>> version are you using. Is HIPE enabled? What svn revision of CouchDB
>> do you have?
>>
>> Cheers
>> Jan
>> --
>>
>>
>> On 27 Feb 2009, at 09:36, Tim Somers wrote:
>>
>> Hi all,
>>>
>>> I've been using couchdb in combination with py-simplecouchdb since a
>>> couple
>>> of weeks now on a small dataset (only 51 docs) with lots of updates.
>>> Yesterday I checked out the latest update from svn, and left my
>>> application
>>> running all night. This morning, the couchdb process had closed.
>>> After restarting it, everything seems to be running fine for read  
>>> access,
>>> but on an update of any document, I get this error:
>>> [debug] [<0.64.0>] 'PUT' /heasys/alert_3505_nomessages {1,1}
>>> Headers: [{'Accept',"application/json, text/javascript, */*"},
>>>        {'Accept-Charset',"ISO-8859-1,utf-8;q=0.7,*;q=0.7"},
>>>        {'Accept-Encoding',"gzip,deflate"},
>>>        {'Accept-Language',"en-us,en;q=0.5"},
>>>        {'Connection',"keep-alive"},
>>>        {'Content-Length',"239"},
>>>        {'Content-Type',"application/json; charset=UTF-8"},
>>>        {'Host',"localhost:5985"},
>>>        {'Keep-Alive',"300"},
>>>        {'Referer',"
>>> http://localhost:5985/_utils/document.html?heasys/alert_3505_nomessages
>>> "},
>>>        {'User-Agent',"Mozilla/5.0 (X11; U; Linux i686; en-US; rv: 
>>> 1.9.0.6)
>>> Gecko/2009020409 Iceweasel/3.0.6 (Debian-3.0.6-1)"},
>>>        {"X-Requested-With","XMLHttpRequest"}]
>>> Segmentation fault
>>> No difference in the error except for the headers whether I test  
>>> it with
>>> my
>>> application or the futon interface.
>>>
>>> Any ideas, anyone?
>>>
>>> Thanks
>>> Tim Somers
>>>
>>
>>


Mime
View raw message