incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Boyd <>
Subject Re: Link trouble on Solaris/SPARC
Date Thu, 04 Dec 2008 23:35:46 GMT
On Thu, Dec 04, 2008 at 01:27:31PM +0000, Noah Slater wrote:
> On Wed, Dec 03, 2008 at 03:56:35PM -0500, Joshua Boyd wrote:
> > So, I guess the question is A) can I just use the old libicu that was already 
> > installed?  B) how to I force this to use the new version in /usr/local/lib
> > instead of the old version in /usr/lib?
> ICU comes with a script called icu-config that the CouchDB build process uses to
> gather information for linking and compiling, and what not. Whatever icu-config
> script is found first on the path when you run ./configure is the one that
> decides what libraries are linked against.
> Run the following two commands to see what your default setup is:
>   icu-config --cppflags-searchpath
>   icu-config --ldflags-searchpath
> There are four ways you can configure this, all using environment variables:
>   * Alter your PATH so that the chosen icu-config script is found first
>   * Override ICU_CONFIG to point to the chosen icu-config script
>   * Override ICU_LOCAL_CFLAGS to the value of "icu-config --cppflags-searchpath"
>   * Override ICU_LOCAL_LDFLAGS to the value of "icu-config --ldflags-searchpath"

/usr/local/bin/icu-config is the first icu-config in the search path,
and icu-config --ldflags-searchpath does show the correct output for
what I desire.

Here is the command line I'm trying:

ICU_LOCAL_CFLAGS=-I/usr/local/include/ ICU_LOCAL_LDFLAGS=-L/usr/local/lib ./configure --prefix=/opt/couchdb-0.8.1/
--with-js-include=/opt/spidermonkey/include/js/ --with-js-lib=/opt/spidermonkey/lib  

After I install, I still have the same error when trying to run it.

$ ldd /opt/couchdb-0.8.1/lib/couchdb/erlang/lib/couch-0.8.1-incubating/priv/lib/ =>         /usr/lib/ =>       /usr/lib/ =>       /usr/lib/ =>   /opt/spidermonkey/lib/ =>       /lib/ =>     /lib/ =>     /lib/ =>  /usr/lib/

>From config.log, I find these lines:
configure:20302: checking ICU_LIBS
configure:20305: result: -xtarget=ultra -xarch=sparc -m64 -lpthread -lm -L/usr/local/lib -licui18n
-licuuc -licudata -lpthread -lm

I've tried swapping the order of /usr/lib and /usr/local/lib in crle:
crle -c /var/ld/ld.config -l

But a gmake clean ; gmake ; gmake install doesn't fix the problem
still.  ldd still shows the same output.

View raw message