incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Davis" <paul.joseph.da...@gmail.com>
Subject Re: Fails to start on OS X after upgrading to 0.8.0
Date Wed, 09 Jul 2008 16:09:50 GMT
On Wed, Jul 9, 2008 at 11:50 AM, Paul Carey <paul.p.carey@gmail.com> wrote:
> Hi all
>
> I initially installed CouchDB 0.7.3 from source without any problems
> on OS X 10.5.2.
> After upgrading to 10.5.3 I installed erlang @R12B-2_1+universal via
> MacPorts to fix the resultant break. I also installed CouchDB via
> MacPorts at this point.
>
> All was working fine till this morning when I upgraded to 10.5.4,
> uninstalled the port install of CouchDB and built from source
> (apache-couchdb-0.8.0-incubating.tar.gz). Now when I start, I get the
> following error
>
> {"init terminating in
> do_boot",{undef,[{crypto,start,[]},{erl_eval,do_apply,5},{init,start_it,1},{init,start_em,1}]}}
>
> After reading around I get the impression that this might be related
> to openssl and the crypto library in erlang.
> Indeed, running crytpo.start(). from erl fails with
> ** exception error: bad function 'crypto.start'
>
> But this puzzles me as my actions today (as far as I can tell) didn't
> involve openssl or erlang.
>
> Any help getting me back up and running would be much appreciated.
>
> Paul
>

I seem to remember someone having pretty much this same exact problem.
Something to do with a libcrypto being slightly off on 10.5. Of course
I can't manage to find the thread, so I'm either making it up or saw
it on IRC.

Paul

Mime
View raw message