incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark James Adams" <mark.james.li...@gmail.com>
Subject Re: crash on startup (undef,[{crypto,start, Solaris)
Date Wed, 04 Jun 2008 21:10:43 GMT
Noah,

> What system and what openssl libraries do you installed?

openssl-0.9.8e on OpenSolaris snv_62.

What I've done now is go entirely 32-bit, so I've rebuilt openssl and erlang.

$ erl
Erlang (BEAM) emulator version 5.6.2 [source] [async-threads:0] [hipe]
[kernel-poll:false]

Eshell V5.6.2  (abort with ^G)
1> crypto:start().
ok

So crypto works. Now I'm getting another problems starting couchdb
(still using the troubleshooting guidelines, I've checked out,
configured, made, and installed couch so many times I'm about to
burst)

$ ./couchdb
couch 0.7.3a650275 (LogLevel=debug)
Apache CouchDB is starting.
[error] [<0.46.0>] {error_report,<0.21.0>,
    {<0.46.0>,supervisor_report,
     [{supervisor,{local,couch_server_sup}},
      {errorContext,start_error},
      {reason,{'EXIT',{error,{open_error,-10}}}},
      {offender,
          [{pid,undefined},
           {name,couch_util},
           {mfa,
               {couch_util,start_link,

["/tmp/couchdb/lib/couchdb/erlang/lib/couch-0.7.3a650275/priv/lib"]}},
           {restart_type,permanent},
           {shutdown,brutal_kill},
           {child_type,worker}]}]}}
Config Info /tmp/couchdb/etc/couchdb/couch.ini:
        CurrentWorkingDir=/tmp/couchdb/bin
        DbRootDir=/tmp/couchdb/var/lib/couchdb
        BindAddress="127.0.0.1"
        Port="5984"
        DocumentRoot=/tmp/couchdb/share/couchdb/www
        LogFile=/tmp/couchdb/var/log/couchdb/couch.log
        UtilDriverDir=/tmp/couchdb/lib/couchdb/erlang/lib/couch-0.7.3a650275/priv/lib
        DbUpdateNotificationProcesses=
        FullTextSearchQueryServer=
        text/javascript=/tmp/couchdb/bin/couchjs
/tmp/couchdb/share/couchdb/server/main.js

…and then it just hangs.

The revision I've checked out might be a few weeks old, I was trying
to match the working OS X version that I have installed locally. Also,
LD_LIBRARY_PATH is set to the path containing ICU.

Thanks.

-- 
Mark James Adams
http://raysend.com/mark/

Mime
View raw message