incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sho Fukamachi <sho.fukama...@gmail.com>
Subject Re: can't install on RHEL4 anymore
Date Sun, 23 Mar 2008 16:42:38 GMT

On 24/03/2008, at 2:44 AM, Christopher Lenz wrote:

> Yeah, SpiderMonkey 1.6 is currently the minimum required version. If  
> it isn't too much trouble, we might be able to support older  
> versions. Try commenting out line 424 in couch_js.c and see if that  
> works. If it does, I'll try to make that bit (the E4X support)  
> optional.

Nope, just shifted the error to the next line:

couch_js.c:423: error: `JSOPTION_NATIVE_BRANCH_CALLBACK' undeclared  
(first use in this function)

and then deleting that line in couch_js.c invited a different error.

> Without any further details on what exactly you did, and how exactly  
> it went wrong, I can't really help much. Can you report back with  
> the content of your config.log file with a couple hundred lines  
> around the "SpiderMonkey" string.

What details do you need? I simply followed the instructions on the  
SpiderMonkey build page: http://developer.mozilla.org/en/docs/SpiderMonkey_Build_Documentation

ie, grabbing the tar and doing a make -f Makefile.ref.

I don't really know what else I am supposed to do with it. It doesn't  
have a make install method - any ideas?

I tried to set configure to use the directory the make outputted to -  
no dice.

And, uh, is it bad if my config.log doesn't have the string  
"spidermonkey" in it at all?

> Well, maybe you are. At least no one else has reported back this  
> problem so far.

It used to work .. ! : )

thanks for the help,

Sho
Mime
View raw message