incubator-couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Lenz <cml...@gmx.de>
Subject Re: can't install on RHEL4 anymore
Date Sun, 23 Mar 2008 15:44:58 GMT
On 23.03.2008, at 11:15, Sho Fukamachi wrote:
> Tried to update my old install on RHEL4 with the latest from trunk  
> and I just can't get it to make. I think it's something to do with  
> spidermonkey - I couldn't find any RPMs for that later than 1.5 or  
> something. Maybe that's too old - ./configure runs, but make bombs  
> out with
>
> couch_js.c:424: error: `JSOPTION_XML' undeclared (first use in this  
> function)
> make[3]: *** [couch_js.o] Error 1
>
> which sounds like SpiderMonkey to me.

Yeah, SpiderMonkey 1.6 is currently the minimum required version. If  
it isn't too much trouble, we might be able to support older versions.  
Try commenting out line 424 in couch_js.c and see if that works. If it  
does, I'll try to make that bit (the E4X support) optional.

> I decided to get a newer one, so downloaded the 1.7.0 js tarball  
> from mozilla and extracted it, then ran configure telling it to look  
> in that directory for  js-lib. Still doesn't work. I tried compiling  
> SpiderMonkey, can't make anything work.

Without any further details on what exactly you did, and how exactly  
it went wrong, I can't really help much. Can you report back with the  
content of your config.log file with a couple hundred lines around the  
"SpiderMonkey" string.

> Has anyone got any idea what I'm doing wrong here? Surely I'm not  
> the only person trying to install on RHEL4...

Well, maybe you are. At least no one else has reported back this  
problem so far.

Cheers,
--
Christopher Lenz
   cmlenz at gmx.de
   http://www.cmlenz.net/


Mime
View raw message