incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joan Touzet (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1572) Remove support for spidermonkey versions < 1.8.5
Date Thu, 01 Aug 2013 01:49:50 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1572?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13725957#comment-13725957
] 

Joan Touzet commented on COUCHDB-1572:
--------------------------------------

Don't misunderstand me, I'm not lobbying against this change on behalf of SmartOS/Solaris,
just highlighting the incompatibility.

There is a workaround (build couchjs and the dependent SM 32-bit), we just need to force that
option in the build process, and error out if we detect any attempt to build couchjs 64-bit
on the platform.
                
> Remove support for spidermonkey versions < 1.8.5
> ------------------------------------------------
>
>                 Key: COUCHDB-1572
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1572
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Build System
>            Reporter: Robert Newson
>             Fix For: 1.5
>
>
> Simplify build system and provide a consistent Javascript environment by ditching spidermonkey
versions below 1.8.5

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message