incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noah Slater <nsla...@apache.org>
Subject Re: why pygnents >= 1.5 ?
Date Tue, 04 Jun 2013 17:33:33 GMT
Benoit, yep. That's exactly why I introduced the dep. Remember: only devs
need this.

+1 for adding rationales to the docs, once we move them to .rst.


On 3 June 2013 22:01, Jan Lehnardt <jan@apache.org> wrote:

>
> On May 29, 2013, at 14:39 , Benoit Chesneau <bchesneau@gmail.com> wrote:
>
> > On Wed, May 29, 2013 at 2:30 PM, Benoit Chesneau <bchesneau@gmail.com>
> wrote:
> >> Why do we need pygments >= 1.5 ? I don't see anything in our doc that
> >> would require it.  Also the version installed on an ubuntu LTD is 1.4.
> >>
> >> So if there are no reason I think we should decrease the requirements
> >> (or simply removing it).
> >>
> >> - benoit
> >
> >
> > Ok I see that http and json lexers require 1.5. So I guess devs need
> > to install it manually if they are using an ubuntu 12.04 or other
> > releases which don't have it.
> >
> > It would be good to keep a list of dependencies versions  we need
> > somewhere (that a human can read) and why so we can make sure that
> > people can keep the minimum or patch. Thoughts?
>
> File an issue, so we don’t forget?
>
> Jan
> --
>
> >
> > - benoit
>
>


-- 
NS

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message