incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Newson <rnew...@apache.org>
Subject Re: [VOTE] Apache CouchDB maintenance releases, first round for 1.0.4, 1.1.2, 1.2.1
Date Wed, 02 Jan 2013 18:42:13 GMT
Thanks for the refinement on your votes. It's common, on OS X, to have
to do a 'while true; ./utils run; done' thing, which I did myself. For
my part, I can't count your +1 for 1.0.4 but I don't think that will
hold up the release.

On 2 January 2013 18:35, Noah Slater <nslater@apache.org> wrote:
> The ASF policy states:
>
> "Before voting +1 PMC members are required to download the signed source
> code package, compile it as provided, and test the resulting executable on
> their own platform, along with also verifying that the package meets the
> requirements of the ASF policy on releases."
>
> I figured that in this instance, it would be useful for me to +1 based on
> correctness of packaging alone. As release managers for this VOTE, I would
> understand it if you want to discount my vote on 1.0.4.
>
> However, my vote on 1.1.2 should be counted. I was able to compile the
> code, and I was able to get a mostly passing test suite. (Which we have
> accepted in the past as being okay.) Unless the failure I got is alarming?
> I can re-run if required.
>
>
> On 2 January 2013 18:10, Robert Newson <rnewson@apache.org> wrote:
>
>> If you can +1 despite being "unable to run the code or run either test
>> suite." then I'm not sure what the release procedure is for.
>>
>> B.
>>
>> On 2 January 2013 17:59, Noah Slater <nslater@apache.org> wrote:
>> > Running all tests with Erlang R15B02 (erts-5.9.2) and SpiderMonkey 1.8.5.
>> >
>> > = 1.0.4 =
>> >
>> > Got as far as:
>> >
>> > ./configure --prefix=/tmp/couchdb/install
>> >
>> > This is from the Checking the Release Artefacts section in the release
>> > procedure. Unable to configure the source because my SpiderMonkey is too
>> > new. Tried to compile from source, but got errors. No available Ubuntu
>> > image has a package old enough. I am happy that the release is fine,
>> > though, obviously, I have been unable to run the code or run either test
>> > suite.
>> >
>> > This artefact gets my +1
>> >
>> > = 1.1.2 =
>> >
>> > Got as far as running the Futon test suite. (Surprised I got this far
>> with
>> > my up-to-date versions of both Erlang and SpiderMonkey.) Extensive
>> > segmentation faults and bus errors. All tests pass except oauth.
>> >
>> > This artefact gets my +1
>> >
>> > = 1.2.1 =
>> >
>> > Completed the Futon test suite. Extensive segmentation faults and bus
>> > errors. All tests pass.
>> >
>> > This artefact gets my +1
>> >
>> >
>> >
>> > On 29 December 2012 20:12, Dave Cottlehuber <dch@apache.org> wrote:
>> >
>> >> Hello,
>> >>
>> >> We would like to call a vote for Apache CouchDB, 1.0.4, 1.1.2, and
>> 1.2.1,
>> >> first round, maintenance releases, to start your New Year with a bang.
>> >>
>> >> We encourage the whole community to download and test these release
>> >> artifacts so that any critical issues can be resolved before the
>> releases
>> >> are made. Everyone is free to vote on this release, so get stuck in!
>> >>
>> >> We are voting on the following release artifacts, by different release
>> >> managers to spread the load.
>> >>
>> >> Robert Newson:
>> >>     http://people.apache.org/~rnewson/dist/1.0.4
>> >>
>> >> Dave Cottlehuber:
>> >>     http://people.apache.org/~dch/dist/1.1.2
>> >>     http://people.apache.org/~dch/dist/1.2.1
>> >>
>> >> PGP Keys:
>> >>     https://people.apache.org/~dch/dist/KEYS
>> >>
>> >> These artifacts have been built from the following git commits:
>> >>
>> >> 1.0.4: 514b7ef95cf67a06f094d56b6ab86b4a770292bd
>> >> 1.1.2: 306a6eb4405de878313b46ef026a6089503b693a
>> >> 1.2.1: 5ebfa8e4bce7322ae0d7b7d95f269425cdb9a46c
>> >>
>> >> Please follow the test procedure before voting:
>> >>
>> >> http://wiki.apache.org/couchdb/Test_procedure
>> >>
>> >> Note the following restrictions for both 1.0.4 and 1.1.2:
>> >>
>> >> Erlang/OTP R14B* or lower
>> >> Spidermonkey 1.8.0rc1 or lower
>> >>
>> >> Thank you.
>> >>
>> >> Happy voting,
>> >> Dave & Bob.
>> >>
>> >>
>> >
>> >
>> > --
>> > NS
>>
>
>
>
> --
> NS

Mime
View raw message