incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Kögl <koeglste...@gmail.com>
Subject Re: COUCHDB-1444 (missing_named_view error on existing javascript design doc and view)
Date Fri, 03 Aug 2012 12:17:57 GMT
Hi,

On Fri, Aug 3, 2012 at 1:50 PM, Robert Newson <robert.newson@gmail.com> wrote:
> Yes, I've been looking into it but I can't induce the condition locally, which hinders
my progress considerably.
>
> I have made a related fix on couchdb master (ce7204b7eb64ac98d4445130fc4e647ed5181da9)
which might have fixed this but I can't confirm.
>
> If you are able to induce this reliably, I would like to work with you to resolve this
issue. IRC is best.

Unfortunately I can't reproduce this reliably. The problem only
appears on one of my production systems, but there rather often (at
least every 2nd day, sometimes even 5 times a day). However, if you
could prepare a patch against 1.2.0, I'd try to patch this system and
see what happens.


-- Stefan


> On 2 Aug 2012, at 22:15, Stefan Kögl wrote:
>
>> Hi,
>>
>> I just wanted to ask if any of the devs would be willing to help with
>> tracking down and solving COUCHDB-1444 (missing_named_view error on
>> existing javascript design doc and view), which has been open since
>> March.
>>
>> Already 7 people who were affected by this issue (some on production
>> systems) have commented on the issue, confirming it for combinations
>> of 1.1.1, 1.2.0, 1.3.0@master (f0d6f19bc8) and R13B03, R14, R15B01,
>> but apparently no one could provide any useful debugging output.
>>
>> I lack the Erlang skills to tackle this issue myself, but I'd like to
>> help with debugging as much as I can.
>>
>> Any feedback, thoughts, etc would be very much appreciated!
>>
>>
>> Thanks,
>>
>> -- Stefan
>

Mime
View raw message