incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoit Chesneau <bchesn...@gmail.com>
Subject Re: replication problems
Date Fri, 15 Jun 2012 06:28:45 GMT
On Sat, Jun 9, 2012 at 8:33 PM, Dustin Sallings <dustin@spy.net> wrote:
>
>        I'm not exactly sure how to report this, so I figured I'd send a message here
instead of just keeping it to myself.
>
>        Since I've switched from Couchbase Single to Apache CouchDB for (almost) all
of my couches, I've been hitting a couple of replication bugs that I used to experience in
Couchbase Single and Filipe eventually fixed.  The fixes seemed to have not made it to Apache
CouchDB.
>
>        I don't know exactly what happens, so I'm hoping Filipe or someone remembers
enough to know what's going on.
>
>
>        Problem #1:  Replication stops.
>
>        This happens very frequently on my laptop.  I end up killing CouchDB and
watch it catch up after it restarts.  However, it also happens on my Mac Mini at home (notable
difference:  It doesn't go to sleep a couple times a day).  Last night, I discovered I was
very far behind on a replication stream on a particular database.  This was not the case
for all databases.  Restarting brought them all back.
>
>
>        Problem #2:  Replication... replicates
>
>        I've had another case where I've ended up with duplicate replication streams.
 Again, restarting puts the count back to the expected 1.  I'm not sure this causes any
problems, but it might correlate with the other.  I only notice it when I go to check status.
>
> --
> dustin sallings
>
>
>

Ar you using _replicate or _replicator ? Anything interresting in logs?

- benoît

Mime
View raw message