incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Joseph Davis (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1399) Rename _rev to _mvcc or _lock
Date Fri, 03 Feb 2012 14:15:53 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13199717#comment-13199717
] 

Paul Joseph Davis commented on COUCHDB-1399:
--------------------------------------------

@Alexander

Yes, all the other bits would need to be renamed to match the new name as well. I honestly
don't care what it's renamed to as long as it doesn't have a revision connotation.

@Dirkjan

If by exceedingly limited you mean removes an entire class of misunderstanding in the community,
then yes. :) But I do think this is something we should at least be considering. Also, I'm
assuming that 2.0 will have other similarly large breaks in API so I don't see this as much
of an issue since its mostly just a renaming of a concept (with no current plans at actually
changing behavior).
                
> Rename _rev to _mvcc or _lock
> -----------------------------
>
>                 Key: COUCHDB-1399
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1399
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: Database Core
>    Affects Versions: 2.0
>            Reporter: Paul Joseph Davis
>             Fix For: 2.0
>
>
> We should rename the "revisions" to "lock" or "token" or some other suitably opaque term
so we stop getting people asking questions about treating them as revisions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message