incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randall Leeds <randall.le...@gmail.com>
Subject Re: curl dependency
Date Wed, 01 Jun 2011 22:09:02 GMT
On Wed, Jun 1, 2011 at 14:33, Arash Bizhan zadeh <arashbi@gmail.com> wrote:
> Hi,
> I am trying to compile couch on RH enterprise. The official RH package for
> curl is 7.15, but Couch needs 7.18. I would like to know what is the best
> way to handle this? Is  there any specific reason that Couch depends on
> 7.18? Can the dependency be downgraded to 7.15?
> Can anybody advise me on how to handle this specific dependency and other
> dependencies ( i.e Erlang) please?
>
> thanks,
> -arash
>

There are specific features used that require the newer version of libcurl.
However, what version are you building from source?
The 1.1.x branch and trunk no longer require curl and configure should
not fail in its absence.

Mime
View raw message