incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Lehnardt (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1078) Port couchjs to newest libmozjs
Date Sat, 16 Apr 2011 22:00:05 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1078?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13020674#comment-13020674
] 

Jan Lehnardt commented on COUCHDB-1078:
---------------------------------------

Can we make it that both 1.1 and 1.2 will compile with everything that currently compile with
in addition to the new release? I don't think we should drop existing compat with 1.2.


> Port couchjs to newest libmozjs
> -------------------------------
>
>                 Key: COUCHDB-1078
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1078
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: JavaScript View Server
>    Affects Versions: 1.0.2
>            Reporter: Chris Coulson
>            Priority: Minor
>         Attachments: COUCHDB-1078.patch, couchjs_ff185.patch, mozjs2.0.patch
>
>
> In the libmozjs shipped with Firefox 4 / xulrunner 2.0, jsapi has changed a fair bit.
It would be nice to add support to couchjs for the latest libmozjs so Linux distro's don't
have to support old versions of it.
> I already have a WIP patch for this

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message