incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Joseph Davis (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COUCHDB-1078) Port couchjs to newest libmozjs
Date Tue, 01 Mar 2011 18:10:36 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1078?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13000995#comment-13000995
] 

Paul Joseph Davis commented on COUCHDB-1078:
--------------------------------------------

I don't remember bumping to a 1.8 requirement. AFAIK, it should still be possible to build
couchjs with 1.7 but I can't say that I've tried lately. The wiki page at least still mentions
1.7 as the minimum dependency and some of the platform specific instruction still use it.
Granted its a wiki so its quite possibly just out of date.

The biggest issue with moving past an official 1.7 dependency is that there's no official
release after 1.7. Once we bump past 1.7 we're either requiring people to use the 1.8rc1 tarball
or to yank a copy from the FF mercurial repository. There's also the issue that after 1.7
we end up requiring people to have a very specific version of autoconf (which is not the same
as our main depenency on autoconf, which means we require two versions of autoconf though
the old autoconf that spidermonkey uses generally has a specific package for it which I've
always found quite odd but never investigated).

I know that we've made it possible to link against a libmozjs provided by a system package
for xulrunner, but that doesn't seem like something we should officially depend on.

So in the end, I would say that it is probably wrong. I'd have to go back and try building
against 1.7 to double check though.

> Port couchjs to newest libmozjs
> -------------------------------
>
>                 Key: COUCHDB-1078
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1078
>             Project: CouchDB
>          Issue Type: Improvement
>          Components: JavaScript View Server
>    Affects Versions: 1.0.2
>            Reporter: Chris Coulson
>            Priority: Minor
>         Attachments: mozjs2.0.patch
>
>
> In the libmozjs shipped with Firefox 4 / xulrunner 2.0, jsapi has changed a fair bit.
It would be nice to add support to couchjs for the latest libmozjs so Linux distro's don't
have to support old versions of it.
> I already have a WIP patch for this

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message