incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filipe David Manana <fdman...@apache.org>
Subject Re: Remove 0.9 upgrade code?
Date Sun, 05 Dec 2010 17:33:09 GMT
On Fri, Dec 3, 2010 at 11:29 AM, Stephen Lewis
<stephenl@yourgolftravel.com> wrote:
>> Haven't tested, but I heard a few times from friends that opening with
>> 1.0.1 a DB file created with 0.10 didn't work properly (therefore
>> likely to not work as well with a 0.9 file).
>
> On that note, we upgraded our production servers from 0.10.1 to 1.0.1
> recently, and the old DB files opened cleanly - we ran with this setup
> for a couple of weeks before compacting (thus rewriting the .couch
> files with 1.0.1), and didn't notice anything untoward.
>
> I don't suppose you remember what kind of problems were reported?

Nop, this was a coffee talk with some friends. In the end they ended
up writing a small script to transfer the data from a 0.10.0 server to
a 1.0.1 server.
They haven't kept a log so I can't see exactly why it failed for them.
I've never seen in this mailing list anyone complaining about it
either.

cheers


>
> Stephen
>
> --
> Stephen Lewis
> CTO
> yourgolftravel.com / spabreaks.com
>



-- 
Filipe David Manana,
fdmanana@gmail.com, fdmanana@apache.org

"Reasonable men adapt themselves to the world.
 Unreasonable men adapt the world to themselves.
 That's why all progress depends on unreasonable men."

Mime
View raw message