incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Newson <robert.new...@gmail.com>
Subject Re: Remove 0.9 upgrade code?
Date Fri, 03 Dec 2010 09:37:32 GMT
+1 on removing it on condition that the code cleanly refuses to open a 0.9 file.


On Thu, Dec 2, 2010 at 8:50 PM, Damien Katz <damien@apache.org> wrote:
> I'm in favor of removing it.
>
> -Damien
>
> On Dec 2, 2010, at 12:13 PM, Filipe David Manana wrote:
>
>> Hello all,
>>
>> While doing an experiment, I started removing all the 0.9 file format
>> upgrade code. This significantly reduces the amount of code we have:
>>
>> https://github.com/fdmanana/couchdb/commit/ab910576ae7bdfb852971aed17a7a91150de651d
>>
>> (please ignore a few other minor changes done in that diff)
>>
>> Do we still need this code? 0.9 is really old, and since we are close
>> to release 1.1, I'm not sure if it makes sense to keep that upgrade
>> code.
>> Haven't tested, but I heard a few times from friends that opening with
>> 1.0.1 a DB file created with 0.10 didn't work properly (therefore
>> likely to not work as well with a 0.9 file).
>>
>> regards,
>>
>>
>> --
>> Filipe David Manana,
>> fdmanana@gmail.com, fdmanana@apache.org
>>
>> "Reasonable men adapt themselves to the world.
>>  Unreasonable men adapt the world to themselves.
>>  That's why all progress depends on unreasonable men."
>
>

Mime
View raw message