incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Truemper (JIRA)" <j...@apache.org>
Subject [jira] Commented: (COUCHDB-720) Pull replication fails due to "401 Authentication required" while push replication works fine
Date Thu, 06 May 2010 08:46:47 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-720?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12864698#action_12864698
] 

Daniel Truemper commented on COUCHDB-720:
-----------------------------------------

Hi,

I just experienced the same behaviour but have some more background information. I have an
nginx reverse proxy for the ssl stuff. On both DBs there are users and admins. From the client
DB I am now trying to do the following in Futon:

- start replication from https://$user:passwd@$server:5984/$db to http://localhost:5984/$db
(on the local machine I am already logged in and on both DBs I am admin).

When I try to replicate using pull replication, all documents are replicated except the design
document. At the time the replicator tries to GET the design document a HTTP 401 is being
sent from the server DB.

When I do the same using push replication the design document is being replicated.

I am unsure if this is intentional but if so I could use a little help ;).

Best
Daniel

> Pull replication fails due to "401 Authentication required" while push replication works
fine
> ---------------------------------------------------------------------------------------------
>
>                 Key: COUCHDB-720
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-720
>             Project: CouchDB
>          Issue Type: Bug
>          Components: Futon, HTTP Interface, Replication
>    Affects Versions: 0.10.1, 0.11
>         Environment: Remote server having Nginx reverse proxy and basic authentication
enabled
>            Reporter: Jochen Kempf
>            Priority: Blocker
>
> Pull replication fails using both Futon Replicator and http request throwing an "401
Authentication required" error. This just happens when design documents are existent.
> Push replication on the other hand works fine.
> See used code here: http://gist.github.com/364072

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message