incubator-couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Lehnardt (JIRA)" <j...@apache.org>
Subject [jira] Created: (COUCHDB-445) '--with-js-lib' and '--with-js-include' don't override a lib named libjs.so|dylib that is part of a standard install with a custom installed libmozjs.so|dylib library
Date Sun, 02 Aug 2009 19:23:14 GMT
'--with-js-lib' and '--with-js-include' don't override a lib named libjs.so|dylib that is part
of a standard install with a custom installed libmozjs.so|dylib library
----------------------------------------------------------------------------------------------------------------------------------------------------------------------

                 Key: COUCHDB-445
                 URL: https://issues.apache.org/jira/browse/COUCHDB-445
             Project: CouchDB
          Issue Type: Bug
          Components: Build System
    Affects Versions: 0.9.1
         Environment: Mac OS X 10.5.7
            Reporter: Jan Lehnardt
            Assignee: Noah Slater
            Priority: Blocker
             Fix For: 0.10


> ls /usr/local/lib/libjs.dylib 
/usr/local/lib/libjs.dylib*

> ls /tmp/lib/
libjs_static.a*	libmozjs.dylib*


./configure --with-js-lib=/tmp/lib/ --with-js-include=/tmp/include/
...
checking for JS_NewContext in -ljs... yes
...
       ^- would have expected:
 ...
 checking for JS_NewContext in -ljs... no
 checking for JS_NewContext in -lmozjs... yes
 ...

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message