incubator-cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrei Mikhailovsky <and...@arhont.com>
Subject SSVM not created after change of Secondary Storage URL
Date Mon, 04 Feb 2013 14:20:03 GMT
Hello guys, 

I am having an issue with the SSVM not starting after I've changed the URL of the secondary
storage server. I am running a single instance of CS 4.0.0 on Centos 6. Here is what I've
done: 

1. I've modified the host and host_details tables in the DB to change the URL of the secondary
storage server. 
2. I've restarted the CS management server 
3. Logged in to CS gui and made sure the secondary storage server shows correct details. It
did. 
4. Restarted SSVM and logged in to SSVM and ran the ssvm check script. It showed that nfs
mountpoint is not mounted. 
5. Verified that SSVM has network and it can reach the nfs server. It did. 
6. Manually mounted the nfs share using: mount -t nfs -o mountproto=tcp server:/path /path.
That worked as well. 
7. Restarted SSVM again and ran the check script again. No joy. 
8. Deleted SSVM server hoping CS would create a new ssvm instance and all will work okay.
The new SSVM is not being created. Log file entries show: 

---- 

2013-02-04 13:57:19,336 DEBUG [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
Zone host is ready, but secondary storage vm template: 3 is not ready on secondary storage:
6 
2013-02-04 13:57:19,336 DEBUG [storage.secondary.SecondaryStorageManagerImpl] (secstorage-1:null)
Zone 1 is not ready to launch secondary storage VM yet 

2013-02-04 13:57:19,444 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null)
Zone host is ready, but console proxy template: 3 is not ready on secondary storage: 6 
2013-02-04 13:57:19,444 DEBUG [cloud.consoleproxy.ConsoleProxyManagerImpl] (consoleproxy-1:null)
Zone 1 is not ready to launch console proxy yet 
2013-02-04 13:57:19,956 DEBUG [network.router.VirtualNetworkApplianceManagerImpl] (RouterStatusMonitor-1:null)
Found 7 routers. 
2013-02-04 13:57:23,600 DEBUG [agent.manager.AgentManagerImpl] (AgentManager-Handler-8:null)
Ping from 21 
2013-02-04 13:57:35,517 DEBUG [agent.manager.AgentManagerImpl] (AgentManager-Handler-13:null)
Ping from 20 
2013-02-04 13:57:41,166 DEBUG [cloud.server.StatsCollector] (StatsCollector-1:null) StorageCollector
is running... 
2013-02-04 13:57:41,168 DEBUG [cloud.server.StatsCollector] (StatsCollector-1:null) There
is no secondary storage VM for secondary storage host nfs://192.168.169.200/cloudstack-secondary


---- 

I do not see any errors or exceptions in the logs. I've even rebooted the CS management server.
Still, no joy (( 

I've checked the vm_template table and the template with id 3 looks okay: 

| 3 | routing-3 | SystemVM Template (KVM) | 8d335295-558c-4378-839a-f2e816aebb6c | 0 | 0 |
SYSTEM | 0 | 64 | http://download.cloud.com/templates/acton/acton-systemvm-02062012.qcow2.bz2
| QCOW2 | 2012-10-29 23:39:25 | NULL | 1 | 2755de1f9ef2ce4d6f2bee2efbb4da92 | SystemVM Template
(KVM) | 0 | 0 | 15 | 1 | 0 | 1 | 0 | KVM | NULL | NULL | 0 | 


The secondary storage host entry has an Alert status (which could cause the problem): 

| 6 | nfs://192.168.169.200/cloudstack-secondary | 8e143df9-580c-481d-9e1d-eadfe7474867 |
Alert | SecondaryStorage | nfs | 255.255.255.0 | 00:19:bb:34:35:1e | 192.168.169.250 | 255.255.255.0
| 00:19:bb:34:35:1e | NULL | NULL | NULL | NULL | NULL | NULL | NULL | NULL | 1 | NULL | NULL
| NULL | nfs://192.168.169.200/cloudstack-secondary | NULL | None | NULL | 0 | NULL | 4.0.0.20121029120443
| 4e31c7b3-9333-3e6f-8a04-86d4bec5b576 | 2064199680 | NULL | nfs://192.168.169.200/cloudstack-secondary
| 1 | 0 | 0 | 1319922183 | NULL | NULL | 2012-10-30 12:31:55 | NULL | 3 | Enabled | 



I am not sure if I can simply change the db entry of the Status column from Alert to UP? I
do not want to loose the secondary storage server as I've got a bunch of templates, isos and
snapshots that I do not want to recreate. Does anyone know what else to try to get back the
SSVM? 

Many thanks 

Andrei 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message