incubator-cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aleksey Samarin <nrg3...@gmail.com>
Subject Re: Problem with bridge
Date Sat, 15 Dec 2012 18:14:09 GMT
 Thx for reply!

Of course! Problem only with inetbr0, another bridges works fine.

To be sure:

cat /proc/sys/net/ipv4/ip_forward
1

cat /etc/sysctl.conf | grep ipv4.ip_forward
net.ipv4.ip_forward=1

Yes, I had a problem with sistemvm.iso, but here only the network problem.

Alex.


2012/12/15 Trevor Francis <trevor@46labs.com>

> Have you set the KVM traffic labels within Cloudstack when you spun up
> your zone?
>
> Do you have IPV4 forwarding on?
>
>
> cat /proc/sys/net/ipv4/ip_forward
>
> If not, turn it on, and make it permanent by:
>
> sysctl -w net.ipv4.ip_forward=1
>
> /etc/sysctl.conf:
> net.ipv4.ip_forward = 1
>
> I also had problems with system ISOs because the latest incubating for
> Ubuntu (this may have already been fixed) does not include the system VM
> ISOs when you do a apt-get install cloud-agent. If you did a source
> install, it may be different.
>
> Just my initial thoughts.
>
>
>
> Trevor Francis
> Partner
> 46 Labs
> http://www.46labs.com | http://www.peeredge.net
> 720-214-3643- Voice
> trevor@46labs.com
>
> Solutions Provider for the Telecom Industry
>
>
> On Dec 15, 2012, at 10:55 AM, Aleksey Samarin <nrg3tik@gmail.com> wrote:
>
> Hi all!
>
> I have a problem with bridge.
> My setup is: Ubuntu/KVM.
> CS 4.0.0-incubating, advanced installation.
> 3 bridges: mgmtbr0, inetbr0 and guestbr0.
> mgmtbr0 - storage+management. inetbr0 - internet. guestbr0 - guest traffic.
> So, after install and configure, ssmv and cpvm starts well,
> but they can't access gateway via inetbr0.(can't ping gw from ssvm or cpvm)
> Trying to find the problem, ran tcpdump on kvm host and saw something like
> this
>
> tcpdump -i inetbr0
>
> ARP, Request who-has xxx.xxx.xxx.xxx tell hostname, length 46
> STP 802.1w, Rapid STP, Flags [Forward], bridge-id
> 8000.d0:7e:28:07:77:0e.8016, length 47
> IP hostname > xxx.xxx.xxx.xxx UDP, length 52
>
> arp -n
> Address                  HWtype  HWaddress           Flags Mask
>            Iface
> 169.254.0.1              ether   fe:00:a9:fe:02:52   C
>                     eth0
>
> Nothing about gateway, any thoughts?
>
> All the best Alex
>
>
>

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message