incubator-cloudstack-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Prasanna Santhanam <prasanna.santha...@citrix.com>
Subject Re: VM instance cannot aquire IP via DHCP when run on other host with Virtual Router/??????
Date Fri, 07 Sep 2012 11:03:40 GMT
On Fri, Sep 07, 2012 at 06:42:27AM -0400, Nguyễn Đình Việt wrote:
> Hi,
> 
> I deployed Cloudstack with 1 Management Server (CentOS 6.03) and 3
> host on XCP 1.1. I created VMs instance run fine. But I have a
> problem. When VMs instance run on other with VR ( Examp: VR run on
> host 1, VM run on node 2) then VMs can not aquire IP address via
> DHCP. If I migrate it to the same host with VR, it’s OK. I use
> advance networking and Network Offering is default (Offering for
> Isolated networks with Source Nat service enabled).
> 

Can you jump in to the VR from the XCP host?
 - ssh -i .ssh/id_rsa.cloud -p 3922 <vr-link-local-ip-on-ui>

Then check if you see dhcp requests when you spin a VM on the
host that does not have your VR. /var/log/messages should show them. 

If no - this issue sounds like something wrong with your VLAN
configuration. If there are no VLANs configured on your switch check
if all packets are broadcast all over or if they are getting ignored.

> 		
> 
> Can u help me to resolve this problem
> 
> Ps: Can u send me detail document about cloudstack networking ? I
> search on internet but most of them doesn’t descipt detail about
> network problem.
> 
>  

-- 
Prasanna.,

Mime
View raw message